aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-sunxi/patches/212-Revert-Avoid-non-portable-sed-construct.patch
diff options
context:
space:
mode:
Diffstat (limited to 'package/boot/uboot-sunxi/patches/212-Revert-Avoid-non-portable-sed-construct.patch')
-rw-r--r--package/boot/uboot-sunxi/patches/212-Revert-Avoid-non-portable-sed-construct.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/package/boot/uboot-sunxi/patches/212-Revert-Avoid-non-portable-sed-construct.patch b/package/boot/uboot-sunxi/patches/212-Revert-Avoid-non-portable-sed-construct.patch
new file mode 100644
index 0000000000..1a5603417a
--- /dev/null
+++ b/package/boot/uboot-sunxi/patches/212-Revert-Avoid-non-portable-sed-construct.patch
@@ -0,0 +1,21 @@
+From 53d123333fa0ddc64b2c55d48366f4582ac6922d Mon Sep 17 00:00:00 2001
+From: Hauke Mehrtens <hauke@hauke-m.de>
+Date: Thu, 20 Jul 2017 19:50:52 +0200
+Subject: [PATCH 212/213] Revert "Avoid non-portable sed construct"
+
+This reverts commit 208db781cad4c24f538658a9cb17e24fa43ca3c9.
+---
+ scripts/Makefile.lib | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+--- a/scripts/Makefile.lib
++++ b/scripts/Makefile.lib
+@@ -309,7 +309,7 @@ quiet_cmd_dtc = DTC $@
+ # Bring in any U-Boot-specific include after the '/dts-v1/;' header
+ cmd_dtc = mkdir -p $(dir ${dtc-tmp}) ; \
+ cat $< $(if $(u_boot_dtsi),\
+- | sed '/^\/ {$$/{x;s%$$%\#include \"$(u_boot_dtsi)\"%;G;}') | \
++ | sed 's%^/ {$$%\#include \"$(u_boot_dtsi)\"\n&%') | \
+ $(CPP) $(dtc_cpp_flags) -x assembler-with-cpp -o $(dtc-tmp) - ; \
+ $(DTC) -O dtb -o $@ -b 0 \
+ -i $(dir $<) $(DTC_FLAGS) \