aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-sunxi/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'package/boot/uboot-sunxi/Makefile')
-rw-r--r--package/boot/uboot-sunxi/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/package/boot/uboot-sunxi/Makefile b/package/boot/uboot-sunxi/Makefile
index 4363445114..abdb263774 100644
--- a/package/boot/uboot-sunxi/Makefile
+++ b/package/boot/uboot-sunxi/Makefile
@@ -172,6 +172,12 @@ define U-Boot/nanopi_neo
BUILD_DEVICES:=friendlyarm_nanopi-neo
endef
+define U-Boot/nanopi_r1
+ BUILD_SUBTARGET:=cortexa7
+ NAME:=U-Boot for NanoPi R1 (H3)
+ BUILD_DEVICES:=friendlyarm_nanopi-r1
+endef
+
define U-Boot/orangepi_r1
BUILD_SUBTARGET:=cortexa7
NAME:=Orange Pi R1 (H2+)
@@ -310,6 +316,7 @@ UBOOT_TARGETS := \
nanopi_neo_air \
nanopi_neo_plus2 \
nanopi_neo2 \
+ nanopi_r1 \
orangepi_zero \
orangepi_r1 \
orangepi_one \