aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-sunxi/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'package/boot/uboot-sunxi/Makefile')
-rw-r--r--package/boot/uboot-sunxi/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/package/boot/uboot-sunxi/Makefile b/package/boot/uboot-sunxi/Makefile
index 8b073497a5..13fb8cb188 100644
--- a/package/boot/uboot-sunxi/Makefile
+++ b/package/boot/uboot-sunxi/Makefile
@@ -126,6 +126,12 @@ define U-Boot/Lamobo_R1
BUILD_DEVICES:=sun7i-a20-lamobo-r1
endef
+define U-Boot/orangepi_r1
+ BUILD_SUBTARGET:=cortexa7
+ NAME:=Orange Pi R1 (H2+)
+ BUILD_DEVICES:=sun8i-h2-plus-orangepi-r1
+endef
+
define U-Boot/orangepi_plus
BUILD_SUBTARGET:=cortexa7
NAME:=Orange Pi Plus (H3)
@@ -164,6 +170,7 @@ UBOOT_TARGETS := \
Linksprite_pcDuino \
Linksprite_pcDuino3 \
Lamobo_R1 \
+ orangepi_r1 \
orangepi_plus \
pangolin \
pine64_plus