aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-mediatek/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'package/boot/uboot-mediatek/Makefile')
-rw-r--r--package/boot/uboot-mediatek/Makefile12
1 files changed, 12 insertions, 0 deletions
diff --git a/package/boot/uboot-mediatek/Makefile b/package/boot/uboot-mediatek/Makefile
index 269c9e5db5..673b4d2aed 100644
--- a/package/boot/uboot-mediatek/Makefile
+++ b/package/boot/uboot-mediatek/Makefile
@@ -54,6 +54,17 @@ define U-Boot/mt7622_bananapi_bpi-r64-sdmmc
DEPENDS:=+trusted-firmware-a-mt7622-sdmmc-2ddr
endef
+define U-Boot/mt7622_bananapi_bpi-r64-snand
+ NAME:=BananaPi R64 (SNAND)
+ UBOOT_CONFIG:=mt7622_bananapi_bpi-r64-snand
+ BUILD_DEVICES:=bananapi_bpi-r64
+ BUILD_SUBTARGET:=mt7622
+ UBOOT_IMAGE:=u-boot.fip
+ BL2_BOOTDEV:=snand
+ BL2_DDRBLOB:=2
+ DEPENDS:=+trusted-firmware-a-mt7622-snand-2ddr
+endef
+
define U-Boot/mt7622_ubnt_unifi-6-lr
NAME:=Ubiquiti UniFi 6 LR
UBOOT_CONFIG:=mt7622_ubnt_unifi-6-lr
@@ -90,6 +101,7 @@ endef
UBOOT_TARGETS := \
mt7622_bananapi_bpi-r64-emmc \
mt7622_bananapi_bpi-r64-sdmmc \
+ mt7622_bananapi_bpi-r64-snand \
mt7622_linksys_e8450 \
mt7622_rfb1 \
mt7622_ubnt_unifi-6-lr \