aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-layerscape/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'package/boot/uboot-layerscape/Makefile')
-rw-r--r--package/boot/uboot-layerscape/Makefile14
1 files changed, 13 insertions, 1 deletions
diff --git a/package/boot/uboot-layerscape/Makefile b/package/boot/uboot-layerscape/Makefile
index ec1b45d70f..98b129f0ff 100644
--- a/package/boot/uboot-layerscape/Makefile
+++ b/package/boot/uboot-layerscape/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=uboot-layerscape
PKG_VERSION:=LSDK-20.04-update-290520
-PKG_RELEASE:=2
+PKG_RELEASE:=$(AUTORELEASE)
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=https://source.codeaurora.org/external/qoriq/qoriq-components/u-boot
@@ -55,6 +55,16 @@ define U-Boot/fsl_ls1043a-rdb-sdboot
UBOOT_CONFIG:=ls1043ardb_tfa
endef
+define U-Boot/fsl_ls1046a-frwy
+ NAME:=NXP LS1046AFRWY
+ UBOOT_CONFIG:=ls1046afrwy_tfa
+endef
+
+define U-Boot/fsl_ls1046a-frwy-sdboot
+ NAME:=NXP LS1046AFRWY SD Card Boot
+ UBOOT_CONFIG:=ls1046afrwy_tfa
+endef
+
define U-Boot/fsl_ls1046a-rdb
NAME:=NXP LS1046ARDB
UBOOT_CONFIG:=ls1046ardb_tfa
@@ -109,6 +119,8 @@ UBOOT_TARGETS := \
fsl_ls1012a-frwy-sdboot \
fsl_ls1043a-rdb \
fsl_ls1043a-rdb-sdboot \
+ fsl_ls1046a-frwy \
+ fsl_ls1046a-frwy-sdboot \
fsl_ls1046a-rdb \
fsl_ls1046a-rdb-sdboot \
fsl_ls1088a-rdb \