aboutsummaryrefslogtreecommitdiffstats
path: root/package/base-files
diff options
context:
space:
mode:
Diffstat (limited to 'package/base-files')
-rw-r--r--package/base-files/Makefile2
-rwxr-xr-xpackage/base-files/files/lib/network/config.sh4
2 files changed, 4 insertions, 2 deletions
diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index 5a6c1a969a..bd77d34382 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=base-files
-PKG_RELEASE:=59
+PKG_RELEASE:=60
PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
PKG_BUILD_DEPENDS:=opkg/host
diff --git a/package/base-files/files/lib/network/config.sh b/package/base-files/files/lib/network/config.sh
index c948c83a85..d285da23ad 100755
--- a/package/base-files/files/lib/network/config.sh
+++ b/package/base-files/files/lib/network/config.sh
@@ -344,12 +344,13 @@ setup_interface() {
local pidfile="/var/run/dhcp-${iface}.pid"
service_kill udhcpc "$pidfile"
- local ipaddr netmask hostname proto1 clientid broadcast
+ local ipaddr netmask hostname proto1 clientid vendorid broadcast
config_get ipaddr "$config" ipaddr
config_get netmask "$config" netmask
config_get hostname "$config" hostname
config_get proto1 "$config" proto
config_get clientid "$config" clientid
+ config_get vendorid "$config" vendorid
config_get_bool broadcast "$config" broadcast 0
[ -z "$ipaddr" ] || \
@@ -364,6 +365,7 @@ setup_interface() {
${ipaddr:+-r $ipaddr} \
${hostname:+-H $hostname} \
${clientid:+-c $clientid} \
+ ${vendorid:+-V $vendorid} \
-b -p "$pidfile" $broadcast \
${dhcpopts:- -O rootpath -R &}
;;