aboutsummaryrefslogtreecommitdiffstats
path: root/package/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'package/Makefile')
-rw-r--r--package/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/package/Makefile b/package/Makefile
index 64efeb3745..17378a95ef 100644
--- a/package/Makefile
+++ b/package/Makefile
@@ -88,7 +88,8 @@ $(curdir)/index: FORCE
@for d in $(PACKAGE_SUBDIRS); do ( \
mkdir -p $$d; \
cd $$d || continue; \
- $(SCRIPT_DIR)/ipkg-make-index.sh . 2>&1 > Packages && \
+ $(SCRIPT_DIR)/ipkg-make-index.sh . 2>&1 > Packages.manifest; \
+ grep -vE '^(Maintainer|LicenseFiles|Source|Require)' Packages.manifest > Packages && \
gzip -9nc Packages > Packages.gz; \
); done
ifdef CONFIG_SIGNED_PACKAGES