aboutsummaryrefslogtreecommitdiffstats
path: root/package/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'package/Makefile')
-rw-r--r--package/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/package/Makefile b/package/Makefile
index a6b34be0f4..d5212f09a8 100644
--- a/package/Makefile
+++ b/package/Makefile
@@ -143,6 +143,14 @@ $(curdir)/index: FORCE
$(SCRIPT_DIR)/ipkg-make-index.sh . 2>&1 > Packages && \
gzip -9c Packages > Packages.gz; \
); done
+ifdef CONFIG_SIGNED_PACKAGES
+ @echo Signing package index...
+ @for d in $(PACKAGE_SUBDIRS); do ( \
+ [ -d $(PACKAGE_DIR)/$$d ] && \
+ cd $(PACKAGE_DIR)/$$d || continue; \
+ $(STAGING_DIR_HOST)/bin/usign -S -m Packages -s $(BUILD_KEY); \
+ ); done
+else
ifeq ($(call qstrip,$(CONFIG_OPKGSMIME_KEY)),)
@echo Signing key has not been configured
else
@@ -161,6 +169,7 @@ else
); done
endif
endif
+endif
$(curdir)/preconfig: