aboutsummaryrefslogtreecommitdiffstats
path: root/openwrt/target/utils/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'openwrt/target/utils/Makefile')
-rw-r--r--openwrt/target/utils/Makefile25
1 files changed, 0 insertions, 25 deletions
diff --git a/openwrt/target/utils/Makefile b/openwrt/target/utils/Makefile
deleted file mode 100644
index 5b0f2470b4..0000000000
--- a/openwrt/target/utils/Makefile
+++ /dev/null
@@ -1,25 +0,0 @@
-include $(TOPDIR)/rules.mk
-
-TARGETS := addpattern trx motorola-bin dgfirmware
-
-UTILS_BUILD_DIR:=$(BUILD_DIR)/target-utils
-
-prepare: $(UTILS_BUILD_DIR)
-compile: prepare $(patsubst %,$(UTILS_BUILD_DIR)/%,$(TARGETS))
- mkdir -p $(STAGING_DIR)/bin
- $(CP) $(UTILS_BUILD_DIR)/* $(STAGING_DIR)/bin/
-install: compile
-package:
-clean:
- rm -rf $(UTILS_BUILD_DIR)
- for f in $(TARGETS); do \
- rm -f $(STAGING_DIR)/bin/$$f ; \
- done
-
-$(UTILS_BUILD_DIR):
- mkdir -p $(UTILS_BUILD_DIR)
-
-$(UTILS_BUILD_DIR)/%: src/%.c
- $(CC) -o $@ $(patsubst $(UTILS_BUILD_DIR)/%,src/%.c,$@)
- chmod 755 $@
-