aboutsummaryrefslogtreecommitdiffstats
path: root/openwrt/package/scanlogd
diff options
context:
space:
mode:
Diffstat (limited to 'openwrt/package/scanlogd')
-rw-r--r--openwrt/package/scanlogd/Config.in14
-rw-r--r--openwrt/package/scanlogd/Makefile45
-rwxr-xr-xopenwrt/package/scanlogd/files/scanlogd.init3
-rw-r--r--openwrt/package/scanlogd/ipkg/scanlogd.control9
-rw-r--r--openwrt/package/scanlogd/ipkg/scanlogd.postinst33
5 files changed, 0 insertions, 104 deletions
diff --git a/openwrt/package/scanlogd/Config.in b/openwrt/package/scanlogd/Config.in
deleted file mode 100644
index 024308edc5..0000000000
--- a/openwrt/package/scanlogd/Config.in
+++ /dev/null
@@ -1,14 +0,0 @@
-config BR2_PACKAGE_SCANLOGD
- prompt "scanlogd.......................... a port scan detection tool"
- tristate
- select BR2_PACKAGE_LIBPCAP
- select BR2_PACKAGE_LIBNET
- select BR2_PACKAGE_LIBNIDS
- default m if CONFIG_DEVEL
- help
- Scanlogd is a TCP port scan detection tool, originally designed
- to illustrate various attacks an IDS developer has to deal with.
- Thus, unlike some of the other port scan detection tools out there,
- scanlogd is designed to be totally safe to use.
-
- http://www.openwall.com/scanlogd
diff --git a/openwrt/package/scanlogd/Makefile b/openwrt/package/scanlogd/Makefile
deleted file mode 100644
index afde593995..0000000000
--- a/openwrt/package/scanlogd/Makefile
+++ /dev/null
@@ -1,45 +0,0 @@
-# $Id$
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=scanlogd
-PKG_VERSION:=2.2.6
-PKG_RELEASE:=1
-PKG_MD5SUM:=7b8187ea718ebe47f22805b921b909ab
-
-PKG_SOURCE_URL:=http://www.openwall.com/scanlogd/ \
- ftp://ftp.wiretapped.net/pub/openwall/ \
- http://distro.ibiblio.org/pub/linux/distributions/openwall/
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
-
-include $(TOPDIR)/package/rules.mk
-
-$(eval $(call PKG_template,SCANLOGD,scanlogd,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-
-$(PKG_BUILD_DIR)/.configured:
- $(SED) "s,/var/empty,/tmp/.scanlogd," $(PKG_BUILD_DIR)/params.h
- $(SED) "s,#undef SCANLOGD_DEVICE,#define SCANLOGD_DEVICE \"all\"," $(PKG_BUILD_DIR)/params.h
- touch $@
-
-$(PKG_BUILD_DIR)/.built:
- $(MAKE) -C $(PKG_BUILD_DIR) \
- $(TARGET_CONFIGURE_OPTS) \
- CC=$(TARGET_CC) LD=$(TARGET_CC) CFLAGS="-c $(TARGET_CFLAGS)" \
- LDFLAGS= \
- PCAP_H="-I$(STAGING_DIR)/usr/include" \
- NIDS_H="-I$(STAGING_DIR)/usr/include" \
- NIDS_L="-L$(STAGING_DIR)/usr/lib -lnids -lnet -lpcap" \
- libnids
- touch $@
-
-$(IPKG_SCANLOGD):
- install -d -m0755 $(IDIR_SCANLOGD)/etc/init.d
- install -m0755 ./files/scanlogd.init $(IDIR_SCANLOGD)/etc/init.d/S60scanlogd
- install -d -m0755 $(IDIR_SCANLOGD)/usr/sbin
- install -m0755 $(PKG_BUILD_DIR)/$(PKG_NAME) $(IDIR_SCANLOGD)/usr/sbin/
- $(RSTRIP) $(IDIR_SCANLOGD)
- $(IPKG_BUILD) $(IDIR_SCANLOGD) $(PACKAGE_DIR)
diff --git a/openwrt/package/scanlogd/files/scanlogd.init b/openwrt/package/scanlogd/files/scanlogd.init
deleted file mode 100755
index 762d55e8cd..0000000000
--- a/openwrt/package/scanlogd/files/scanlogd.init
+++ /dev/null
@@ -1,3 +0,0 @@
-#!/bin/sh
-mkdir -p `grep "^scanlogd:" /etc/passwd | cut -d: -f6`
-/usr/sbin/scanlogd
diff --git a/openwrt/package/scanlogd/ipkg/scanlogd.control b/openwrt/package/scanlogd/ipkg/scanlogd.control
deleted file mode 100644
index 307a8dd570..0000000000
--- a/openwrt/package/scanlogd/ipkg/scanlogd.control
+++ /dev/null
@@ -1,9 +0,0 @@
-Package: scanlogd
-Priority: optional
-Section: net
-Version: [TBDL]
-Architecture: [TBDL]
-Maintainer: OpenWrt Developer <bugs@openwrt.org>
-Description: Port scan logger.
-Source: http://www.openwall.com/scanlogd/
-Depends: libpcap, libnet, libnids
diff --git a/openwrt/package/scanlogd/ipkg/scanlogd.postinst b/openwrt/package/scanlogd/ipkg/scanlogd.postinst
deleted file mode 100644
index ab720092c7..0000000000
--- a/openwrt/package/scanlogd/ipkg/scanlogd.postinst
+++ /dev/null
@@ -1,33 +0,0 @@
-#!/bin/sh
-
-name=scanlogd
-id=53
-
-# do not change below
-# check if we are on real system
-if [ -z "${IPKG_INSTROOT}" ]; then
- # create copies of passwd and group, if we use squashfs
- rootfs=`mount |awk '/root/ { print $5 }'`
- if [ "$rootfs" = "squashfs" ]; then
- if [ -h /etc/group ]; then
- rm /etc/group
- cp /rom/etc/group /etc/group
- fi
- if [ -h /etc/passwd ]; then
- rm /etc/passwd
- cp /rom/etc/passwd /etc/passwd
- fi
- fi
-fi
-
-echo ""
-if [ -z "$(grep ^\\${name}: ${IPKG_INSTROOT}/etc/group)" ]; then
- echo "adding group $name to /etc/group"
- echo "${name}:x:${id}:" >> ${IPKG_INSTROOT}/etc/group
-fi
-
-if [ -z "$(grep ^\\${name}: ${IPKG_INSTROOT}/etc/passwd)" ]; then
- echo "adding user $name to /etc/passwd"
- echo "${name}:x:${id}:${id}:${name}:/tmp/.${name}:/bin/false" >> ${IPKG_INSTROOT}/etc/passwd
-fi
-