aboutsummaryrefslogtreecommitdiffstats
path: root/openwrt/package/portsentry
diff options
context:
space:
mode:
Diffstat (limited to 'openwrt/package/portsentry')
-rw-r--r--openwrt/package/portsentry/Config.in9
-rw-r--r--openwrt/package/portsentry/Makefile37
-rw-r--r--openwrt/package/portsentry/ipkg/portsentry.conffiles1
-rw-r--r--openwrt/package/portsentry/ipkg/portsentry.control4
-rw-r--r--openwrt/package/portsentry/patches/100-conf_location.patch11
-rw-r--r--openwrt/package/portsentry/patches/101-postsentry_c.patch12
6 files changed, 0 insertions, 74 deletions
diff --git a/openwrt/package/portsentry/Config.in b/openwrt/package/portsentry/Config.in
deleted file mode 100644
index f7acc18534..0000000000
--- a/openwrt/package/portsentry/Config.in
+++ /dev/null
@@ -1,9 +0,0 @@
-config BR2_PACKAGE_PORTSENTRY
- prompt "portsentry........................ Portscan protection utility"
- tristate
- default m if CONFIG_DEVEL
- help
- Software for protection against port scans
-
- http://sourceforge.net/projects/sentrytools
-
diff --git a/openwrt/package/portsentry/Makefile b/openwrt/package/portsentry/Makefile
deleted file mode 100644
index 18cfec71e6..0000000000
--- a/openwrt/package/portsentry/Makefile
+++ /dev/null
@@ -1,37 +0,0 @@
-# $Id$
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=portsentry
-PKG_VERSION:=1.2
-PKG_RELEASE:=1
-PKG_MD5SUM:=3ebd3618ba9abfea2525e236bd44cebd
-
-PKG_SOURCE_URL:=@SF/sentrytools
-PKG_SOURCE:=$(PKG_NAME)-1.2.tar.gz
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)_beta
-
-include $(TOPDIR)/package/rules.mk
-
-$(eval $(call PKG_template,PORTSENTRY,portsentry,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-
-$(PKG_BUILD_DIR)/.configured:
- touch $@
-
-$(PKG_BUILD_DIR)/.built:
- $(MAKE) -C $(PKG_BUILD_DIR) linux
- touch $@
-
-$(IPKG_PORTSENTRY):
- mkdir -p $(IDIR_PORTSENTRY)/usr/bin
- mkdir -p $(IDIR_PORTSENTRY)/etc
- $(CP) $(PKG_BUILD_DIR)/$(PKG_NAME).conf $(IDIR_PORTSENTRY)/etc/
- $(CP) $(PKG_BUILD_DIR)/$(PKG_NAME) $(IDIR_PORTSENTRY)/usr/bin/
- $(STRIP) $(IDIR_PORTSENTRY)/usr/bin/*
- $(IPKG_BUILD) $(IDIR_PORTSENTRY) $(PACKAGE_DIR)
-
-mostlyclean:
- $(MAKE) -C $(PKG_BUILD_DIR) clean
- rm -f $(PKG_BUILD_DIR)/.built
diff --git a/openwrt/package/portsentry/ipkg/portsentry.conffiles b/openwrt/package/portsentry/ipkg/portsentry.conffiles
deleted file mode 100644
index 9c0810ccbe..0000000000
--- a/openwrt/package/portsentry/ipkg/portsentry.conffiles
+++ /dev/null
@@ -1 +0,0 @@
-/etc/portsentry.conf
diff --git a/openwrt/package/portsentry/ipkg/portsentry.control b/openwrt/package/portsentry/ipkg/portsentry.control
deleted file mode 100644
index f05b282df0..0000000000
--- a/openwrt/package/portsentry/ipkg/portsentry.control
+++ /dev/null
@@ -1,4 +0,0 @@
-Package: portsentry
-Priority: optional
-Section: net
-Description: Software for protection against port scans
diff --git a/openwrt/package/portsentry/patches/100-conf_location.patch b/openwrt/package/portsentry/patches/100-conf_location.patch
deleted file mode 100644
index 457c9c827b..0000000000
--- a/openwrt/package/portsentry/patches/100-conf_location.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- portsentry/portsentry_config.h 2003-05-23 20:10:13.000000000 +0200
-+++ portsentry.old/portsentry_config.h 2005-07-09 21:21:15.000000000 +0200
-@@ -22,7 +22,7 @@
-
- /* These are probably ok. Be sure you change the Makefile if you */
- /* change the path */
--#define CONFIG_FILE "/usr/local/psionic/portsentry/portsentry.conf"
-+#define CONFIG_FILE "/etc/portsentry.conf"
-
- /* The location of Wietse Venema's TCP Wrapper hosts.deny file */
- #define WRAPPER_HOSTS_DENY "/etc/hosts.deny"
diff --git a/openwrt/package/portsentry/patches/101-postsentry_c.patch b/openwrt/package/portsentry/patches/101-postsentry_c.patch
deleted file mode 100644
index e36bb2a123..0000000000
--- a/openwrt/package/portsentry/patches/101-postsentry_c.patch
+++ /dev/null
@@ -1,12 +0,0 @@
---- portsentry/portsentry.c 2003-05-23 20:10:13.000000000 +0200
-+++ portsentry.old/portsentry.c 2005-07-09 21:57:24.000000000 +0200
-@@ -1581,8 +1581,7 @@
- Usage (void)
- {
- printf ("PortSentry - Port Scan Detector.\n");
-- printf ("Copyright 1997-2003 Craig H. Rowland <craigrowland at users dot
--sourceforget dot net>\n");
-+ printf ("Copyright 1997-2003 Craig H. Rowland <craigrowland at users dot sourceforget dot net>\n");
- printf ("Licensing restrictions apply. Please see documentation\n");
- printf ("Version: %s\n\n", VERSION);
- #ifdef SUPPORT_STEALTH