aboutsummaryrefslogtreecommitdiffstats
path: root/openwrt/package/mrd6
diff options
context:
space:
mode:
Diffstat (limited to 'openwrt/package/mrd6')
-rw-r--r--openwrt/package/mrd6/Config.in14
-rw-r--r--openwrt/package/mrd6/Makefile45
-rw-r--r--openwrt/package/mrd6/files/mrd6.conf14
-rwxr-xr-xopenwrt/package/mrd6/files/mrd6.init29
-rw-r--r--openwrt/package/mrd6/ipkg/mrd6.control6
-rw-r--r--openwrt/package/mrd6/patches/01-ceilf_replacement.patch21
6 files changed, 0 insertions, 129 deletions
diff --git a/openwrt/package/mrd6/Config.in b/openwrt/package/mrd6/Config.in
deleted file mode 100644
index cacebe2ac4..0000000000
--- a/openwrt/package/mrd6/Config.in
+++ /dev/null
@@ -1,14 +0,0 @@
-config BR2_PACKAGE_MRD6
- prompt "mrd6.............................. IPv6 multicast routing daemon"
- tristate
- default m if CONFIG_DEVEL
- help
- Multicast is becoming a major component in next generation
- networks, used in several scenarios, from video broadcasting
- to multimedia conferencing. In order to be implemented, new
- technology needs supporting hardware and software across a set
- of devices and systems. MRD6 is an implementation of a modular
- IPv6 Multicast Routing Framework for the Linux operating system
- and provides MLDv2 (as well as MLDv1), PIM-SM and MBGP support.
-
- http://artemis.av.it.pt/mrd6/
diff --git a/openwrt/package/mrd6/Makefile b/openwrt/package/mrd6/Makefile
deleted file mode 100644
index ea92943b3c..0000000000
--- a/openwrt/package/mrd6/Makefile
+++ /dev/null
@@ -1,45 +0,0 @@
-# $Id$
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=mrd6
-PKG_VERSION:=0.9.5
-PKG_RELEASE:=1
-PKG_MD5SUM:=24a08cf1407000d628a272b08a415dda
-
-PKG_SOURCE_URL:=http://hng.av.it.pt/mrd6/download/
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
-
-include $(TOPDIR)/package/rules.mk
-
-$(eval $(call PKG_template,MRD6,$(PKG_NAME),$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-
-$(PKG_BUILD_DIR)/.configured:
- touch $@
-
-$(PKG_BUILD_DIR)/.built:
- $(MAKE) -C $(PKG_BUILD_DIR)/src \
- OPTIMIZE=yes \
- SPACE_OPTIMIZE=yes \
- FULL_STATIC=yes \
- CFLAGS="$(TARGET_CFLAGS) -DNO_INET6_OPTION" \
- CXX=$(TARGET_CROSS)g++ \
- CC=$(TARGET_CC) \
- STAGING_DIR=$(STAGING_DIR) \
- DESTDIR=$(PKG_INSTALL_DIR) \
- PREFIX=/usr/ \
- install
- install -d -m0755 $(PKG_INSTALL_DIR)/etc/init.d
- install -m0644 files/$(PKG_NAME).conf $(PKG_INSTALL_DIR)/etc
- install -m0755 files/$(PKG_NAME).init $(PKG_INSTALL_DIR)/etc/init.d/S60$(PKG_NAME)
- touch $@
-
-$(IPKG_MRD6):
- mkdir -p $(IDIR_MRD6)/usr/sbin
- $(CP) $(PKG_INSTALL_DIR)/ $(IDIR_MRD6)/
- $(RSTRIP) $(IDIR_MRD6)/
- $(IPKG_BUILD) $(IDIR_MRD6) $(PACKAGE_DIR)
diff --git a/openwrt/package/mrd6/files/mrd6.conf b/openwrt/package/mrd6/files/mrd6.conf
deleted file mode 100644
index 84ce923a34..0000000000
--- a/openwrt/package/mrd6/files/mrd6.conf
+++ /dev/null
@@ -1,14 +0,0 @@
-log {
- attach stderr normal;
- attach default "/var/log/mrd6.log" message_err;
-}
-
-interfaces br0 enable = false; // Should be vlan0 + eth1 but Linux bridge seems broken for multicast
-interfaces eth0 enable = false; // Interface to internal bridge
-handle-proper-bridge = true; // use ETH_P_ALL to see all packets on wrt54g
-
-// The default configured RP is m6bone's Renater RP.
-// Change this according to your setup
-
-groups ff00::/8 pim rp = 2001:660:3007:300:1::;
-
diff --git a/openwrt/package/mrd6/files/mrd6.init b/openwrt/package/mrd6/files/mrd6.init
deleted file mode 100755
index 886723f15e..0000000000
--- a/openwrt/package/mrd6/files/mrd6.init
+++ /dev/null
@@ -1,29 +0,0 @@
-#!/bin/sh
-
-case $1 in
-start)
- /sbin/lsmod | grep ipv6 > /dev/null
- if [ "$?" != "0" ]
- then
- echo -n "IPv6 stack required by mrd6. Loading ipv6 module: "
- /sbin/insmod ipv6
- echo "Done."
- fi
- echo -n "Starting IPv6 multicast router (mrd6): "
- /usr/sbin/mrd6 -f /etc/mrd6.conf -D
- echo "Done."
- ;;
-stop)
- echo -n "Stopping IPv6 multicast router (mrd6): "
- killall mrd6
- echo "Done."
- ;;
-restart)
- $0 stop
- $0 start
- ;;
-*)
- echo "Usage: $0 {start | stop | restart}"
- ;;
-esac
-exit 0
diff --git a/openwrt/package/mrd6/ipkg/mrd6.control b/openwrt/package/mrd6/ipkg/mrd6.control
deleted file mode 100644
index 3a50f17131..0000000000
--- a/openwrt/package/mrd6/ipkg/mrd6.control
+++ /dev/null
@@ -1,6 +0,0 @@
-Package: mrd6
-Architecture: mipsel
-Section: net
-Priority: optional
-Depends: kmod-ipv6, libnotimpl
-Description: IPv6 multicast routing daemon
diff --git a/openwrt/package/mrd6/patches/01-ceilf_replacement.patch b/openwrt/package/mrd6/patches/01-ceilf_replacement.patch
deleted file mode 100644
index 1b4ac6213c..0000000000
--- a/openwrt/package/mrd6/patches/01-ceilf_replacement.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-diff -urN mrd6-0.9.5/src/Makefile mrd6-0.9.5.new/src/Makefile
---- mrd6-0.9.5/src/Makefile 2005-12-18 19:15:04.000000000 +0100
-+++ mrd6-0.9.5.new/src/Makefile 2006-02-11 18:30:44.000000000 +0100
-@@ -43,7 +43,7 @@
- CFLAGS += -DNO_INET6_OPTION
- endif
-
--DEST_PREFIX = $(DESTDIR)$(PREFIX)
-+DEST_PREFIX = $(DESTDIR)/$(PREFIX)
-
- ifeq ($(OPTIMIZE),yes)
- ifeq ($(SPACE_OPTIMIZE),yes)
-@@ -97,7 +97,7 @@
- endif
- endif
-
--LDFLAGS += -lm
-+LDFLAGS += -lm -lnotimpl -L$(STAGING_DIR)/usr/lib
- ifeq ($(PLATFORM),OS_LINUX)
- LDFLAGS += -ldl
- endif