aboutsummaryrefslogtreecommitdiffstats
path: root/openwrt/package/motion
diff options
context:
space:
mode:
Diffstat (limited to 'openwrt/package/motion')
-rw-r--r--openwrt/package/motion/Config.in9
-rw-r--r--openwrt/package/motion/Makefile70
-rw-r--r--openwrt/package/motion/ipkg/motion.control5
-rw-r--r--openwrt/package/motion/patches/01-ffmpeg.patch38
-rw-r--r--openwrt/package/motion/patches/02-honor_cppflags.patch20
5 files changed, 0 insertions, 142 deletions
diff --git a/openwrt/package/motion/Config.in b/openwrt/package/motion/Config.in
deleted file mode 100644
index 7d5203691e..0000000000
--- a/openwrt/package/motion/Config.in
+++ /dev/null
@@ -1,9 +0,0 @@
-config BR2_PACKAGE_MOTION
- prompt "motion............................ webcam motion sensing and logging"
- tristate
- default m if CONFIG_DEVEL
- select BR2_PACKAGE_LIBJPEG
- help
- Motion is a software motion detector
-
- http://www.lavrsen.dk/twiki/bin/view/Motion/WebHome
diff --git a/openwrt/package/motion/Makefile b/openwrt/package/motion/Makefile
deleted file mode 100644
index dafe4877d4..0000000000
--- a/openwrt/package/motion/Makefile
+++ /dev/null
@@ -1,70 +0,0 @@
-# $Id$
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=motion
-PKG_VERSION:=3.2.6
-PKG_RELEASE:=1
-PKG_MD5SUM:=71e6bd13fcca70372e9b7c7806d62b30
-
-PKG_SOURCE_URL:=@SF/motion
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
-
-include $(TOPDIR)/package/rules.mk
-
-$(eval $(call PKG_template,MOTION,motion,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-
-$(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.prepared
- (cd $(PKG_BUILD_DIR); \
- $(TARGET_CONFIGURE_OPTS) \
- CFLAGS="$(TARGET_CFLAGS)" \
- CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
- LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
- ./configure \
- --target=$(GNU_TARGET_NAME) \
- --host=$(GNU_TARGET_NAME) \
- --build=$(GNU_HOST_NAME) \
- --program-prefix="" \
- --program-suffix="" \
- --prefix=/usr \
- --exec-prefix=/usr \
- --bindir=/usr/bin \
- --datadir=/usr/share \
- --includedir=/usr/include \
- --infodir=/usr/share/info \
- --libdir=/usr/lib \
- --libexecdir=/usr/lib \
- --localstatedir=/var \
- --mandir=/usr/share/man \
- --sbindir=/usr/sbin \
- --sysconfdir=/etc \
- $(DISABLE_LARGEFILE) \
- $(DISABLE_NLS) \
- --without-ffmpeg \
- --without-jpeg-mmx \
- --without-mysql \
- --without-pgsql \
- );
- touch $@
-
-$(PKG_BUILD_DIR)/.built:
- rm -rf $(PKG_INSTALL_DIR)
- mkdir -p $(PKG_INSTALL_DIR)
- $(MAKE) -C $(PKG_BUILD_DIR) \
- DESTDIR="$(PKG_INSTALL_DIR)" \
- all install
- touch $@
-
-$(IPKG_MOTION):
- install -d -m0755 $(IDIR_MOTION)/usr/bin
- $(CP) $(PKG_INSTALL_DIR)/usr/bin/motion $(IDIR_MOTION)/usr/bin/
- $(RSTRIP) $(IDIR_MOTION)
- $(IPKG_BUILD) $(IDIR_MOTION) $(PACKAGE_DIR)
-
-mostlyclean:
- -$(MAKE) -C $(PKG_BUILD_DIR) clean
- rm -f $(PKG_BUILD_DIR)/.built
diff --git a/openwrt/package/motion/ipkg/motion.control b/openwrt/package/motion/ipkg/motion.control
deleted file mode 100644
index 44a0c2b914..0000000000
--- a/openwrt/package/motion/ipkg/motion.control
+++ /dev/null
@@ -1,5 +0,0 @@
-Package: motion
-Priority: optional
-Section: multimedia
-Depends: libjpeg, libpthread
-Description: Webcam motion sensing and logging
diff --git a/openwrt/package/motion/patches/01-ffmpeg.patch b/openwrt/package/motion/patches/01-ffmpeg.patch
deleted file mode 100644
index 1f4c73eafa..0000000000
--- a/openwrt/package/motion/patches/01-ffmpeg.patch
+++ /dev/null
@@ -1,38 +0,0 @@
-diff -ur motion-3.2.5.1-old/motion.c motion-3.2.5.1/motion.c
---- motion-3.2.5.1-old/motion.c 2006-03-17 10:05:13.490000000 -0800
-+++ motion-3.2.5.1/motion.c 2006-03-17 10:03:38.020000000 -0800
-@@ -1246,10 +1246,10 @@
- * Note: Negative value means SIGALRM snaps are enabled
- * httpd-control snaps are always enabled.
- */
--
-+#ifdef HAVE_FFMPEG
- /* time_current_frame is used both for snapshot and timelapse features */
- time_current_frame = cnt->currenttime;
--
-+
- if ( (cnt->conf.snapshot_interval > 0 && cnt->shots == 0 &&
- time_current_frame % cnt->conf.snapshot_interval <= time_last_frame % cnt->conf.snapshot_interval) ||
- cnt->snapshot) {
-@@ -1257,7 +1257,7 @@
- cnt->snapshot = 0;
- }
-
--
-+#endif /* HAVE_FFMPEG */
- /***** MOTION LOOP - TIMELAPSE FEATURE SECTION *****/
-
- #ifdef HAVE_FFMPEG
-@@ -1331,10 +1331,9 @@
- event(cnt, EVENT_TIMELAPSEEND, NULL, NULL, NULL, cnt->currenttime_tm);
-
-
--#endif /* HAVE_FFMPEG */
-
- time_last_frame = time_current_frame;
--
-+#endif /* HAVE_FFMPEG */
-
- /***** MOTION LOOP - VIDEO LOOPBACK SECTION *****/
-
-Only in motion-3.2.5.1-old/: motion.c.orig
diff --git a/openwrt/package/motion/patches/02-honor_cppflags.patch b/openwrt/package/motion/patches/02-honor_cppflags.patch
deleted file mode 100644
index 322fb772d3..0000000000
--- a/openwrt/package/motion/patches/02-honor_cppflags.patch
+++ /dev/null
@@ -1,20 +0,0 @@
-diff -ruN motion-3.2.5.1-old/Makefile.in motion-3.2.5.1-new/Makefile.in
---- motion-3.2.5.1-old/Makefile.in 2006-03-07 22:52:49.000000000 +0100
-+++ motion-3.2.5.1-new/Makefile.in 2006-03-27 22:04:34.000000000 +0200
-@@ -32,6 +32,7 @@
- ################################################################################
- CFLAGS = @CFLAGS@ -Wall -DVERSION=\"$(VERSION)\" -D_REENTRANT \
- -Dsysconfdir=\"$(sysconfdir)\"
-+CPPFLAGS = @CPPFLAGS@
- LDFLAGS = @LDFLAGS@
- LIBS = @LIBS@
- VIDEO_OBJ = @VIDEO@
-@@ -115,7 +116,7 @@
- ################################################################################
- $(DEPEND_FILE): *.h $(SRC)
- @echo "Generating dependencies, please wait..."
-- @$(CC) $(CFLAGS) -M $(SRC) > .tmp
-+ @$(CC) $(CFLAGS) $(CPPFLAGS) -M $(SRC) > .tmp
- @mv -f .tmp $(DEPEND_FILE)
- @echo
-