aboutsummaryrefslogtreecommitdiffstats
path: root/openwrt/package/miax
diff options
context:
space:
mode:
Diffstat (limited to 'openwrt/package/miax')
-rw-r--r--openwrt/package/miax/Config.in12
-rw-r--r--openwrt/package/miax/Makefile36
-rw-r--r--openwrt/package/miax/ipkg/miax.control5
-rw-r--r--openwrt/package/miax/patches/01-cross.patch24
4 files changed, 0 insertions, 77 deletions
diff --git a/openwrt/package/miax/Config.in b/openwrt/package/miax/Config.in
deleted file mode 100644
index 9cd66b1bbe..0000000000
--- a/openwrt/package/miax/Config.in
+++ /dev/null
@@ -1,12 +0,0 @@
-config BR2_PACKAGE_MIAX
- prompt "miax.............................. A console iax (asterisk) client"
- tristate
- default m if CONFIG_DEVEL
- select BR2_PACKAGE_BLUEZ_LIBS
- select BR2_PACKAGE_LIBPTHREAD
- help
- miax is a console iax (asterisk) client, it can work with
- a soundcard as a normal voip phone, taking input/output from
- keyboard, analog/gsm/isdn modem or bluetooth phones.
-
- http://www.eja.it/?l=gpl&testo=miax
diff --git a/openwrt/package/miax/Makefile b/openwrt/package/miax/Makefile
deleted file mode 100644
index e121f8df14..0000000000
--- a/openwrt/package/miax/Makefile
+++ /dev/null
@@ -1,36 +0,0 @@
-# $Id$
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=miax
-PKG_VERSION:=1.4
-PKG_RELEASE:=1
-PKG_MD5SUM:=44f0d2ef46ee2697d890b7b96846adc7
-
-PKG_SOURCE_URL:=http://mesh.dl.sourceforge.net/sourceforge/miax/
-PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).tar.gz
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
-
-include $(TOPDIR)/package/rules.mk
-
-$(eval $(call PKG_template,MIAX,miax,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-
-$(PKG_BUILD_DIR)/.configured:
- touch $@
-
-$(PKG_BUILD_DIR)/.built:
- $(MAKE) -C "$(PKG_BUILD_DIR)" \
- CC="$(TARGET_CC)" \
- OFLAGS="$(TARGET_CFLAGS)" \
- CPPFLAGS="-I$(STAGING_DIR)/usr/include" \
- LDFLAGS="-L$(STAGING_DIR)/usr/lib" \
- all
- touch $@
-
-$(IPKG_MIAX):
- install -d -m0755 $(IDIR_MIAX)/usr/bin
- install -m0755 $(PKG_BUILD_DIR)/miax $(IDIR_MIAX)/usr/bin/
- $(RSTRIP) $(IDIR_MIAX)
- $(IPKG_BUILD) $(IDIR_MIAX) $(PACKAGE_DIR)
diff --git a/openwrt/package/miax/ipkg/miax.control b/openwrt/package/miax/ipkg/miax.control
deleted file mode 100644
index 78e47f566d..0000000000
--- a/openwrt/package/miax/ipkg/miax.control
+++ /dev/null
@@ -1,5 +0,0 @@
-Package: miax
-Priority: optional
-Section: net
-Description: A console iax (asterisk) client
-Depends: kmod-bluetooth, bluez-libs, libpthread
diff --git a/openwrt/package/miax/patches/01-cross.patch b/openwrt/package/miax/patches/01-cross.patch
deleted file mode 100644
index f47c1101d9..0000000000
--- a/openwrt/package/miax/patches/01-cross.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-diff -ruN miax-1.4-old/Makefile miax-1.4-new/Makefile
---- miax-1.4-old/Makefile 2005-04-27 18:56:13.000000000 +0200
-+++ miax-1.4-new/Makefile 2005-11-30 01:07:21.000000000 +0100
-@@ -1,4 +1,5 @@
--CFLAGS= -Iiax/ -Igsm/inc -DIAXC_IAX2 -DLIBIAX -g -DPOSIXSLEEP -DLINUX -O2
-+OFLAGS= -02 -g
-+CFLAGS= -Iiax/ -Igsm/inc $(CPPFLAGS) -DIAXC_IAX2 -DLIBIAX -DPOSIXSLEEP -DLINUX $(OFLAGS)
- SYSLIBS=-lpthread -lm -lbluetooth
-
-
-@@ -32,11 +33,10 @@
- miax.o
-
- all: $(OBJS)
-- gcc $(OBJS) $(CFLAGS) $(SYSLIBS) -o miax
-- cp miax /bin/miax
-+ $(CC) $(OBJS) $(CFLAGS) $(LDFLAGS) $(SYSLIBS) -o miax
-
- static: $(OBJS) bluetooth.o
-- gcc $(OBJS) $(CFLAGS) $(SYSLIBS) -static -o miax
-+ $(CC) $(OBJS) $(CFLAGS) $(LDFLAGS) $(SYSLIBS) -static -o miax
-
- clean:
- rm -f $(OBJS) miax