aboutsummaryrefslogtreecommitdiffstats
path: root/openwrt/package/libpcap/patches
diff options
context:
space:
mode:
Diffstat (limited to 'openwrt/package/libpcap/patches')
-rw-r--r--openwrt/package/libpcap/patches/100-shared-lib.patch120
-rw-r--r--openwrt/package/libpcap/patches/101-cross-compile-fix.patch12
-rw-r--r--openwrt/package/libpcap/patches/102-alt-ether.patch40
3 files changed, 0 insertions, 172 deletions
diff --git a/openwrt/package/libpcap/patches/100-shared-lib.patch b/openwrt/package/libpcap/patches/100-shared-lib.patch
deleted file mode 100644
index 54cc774a37..0000000000
--- a/openwrt/package/libpcap/patches/100-shared-lib.patch
+++ /dev/null
@@ -1,120 +0,0 @@
-diff -urN libpcap-0.9.4.orig/Makefile.in libpcap-0.9.4/Makefile.in
---- libpcap-0.9.4.orig/Makefile.in 2003-12-15 02:35:03.000000000 +0100
-+++ libpcap-0.9.4/Makefile.in 2006-02-05 16:56:18.000000000 +0100
-@@ -37,6 +37,15 @@
- srcdir = @srcdir@
- VPATH = @srcdir@
-
-+# some defines for shared library compilation
-+MAJ=0.9
-+MIN=4
-+VERSION=$(MAJ).$(MIN)
-+LIBNAME=pcap
-+LIBRARY=lib$(LIBNAME).a
-+SOLIBRARY=lib$(LIBNAME).so
-+SHAREDLIB=$(SOLIBRARY).$(VERSION)
-+
- #
- # You shouldn't need to edit anything below.
- #
-@@ -50,6 +59,7 @@
-
- # Standard CFLAGS
- CFLAGS = $(CCOPT) $(INCLS) $(DEFS)
-+CFLAGS_SHARED = -shared -Wl,-soname,$(SOLIBRARY).$(MAJ)
-
- INSTALL = @INSTALL@
- INSTALL_PROGRAM = @INSTALL_PROGRAM@
-@@ -70,7 +80,12 @@
- .c.o:
- @rm -f $@
- $(CC) $(CFLAGS) -c $(srcdir)/$*.c
-+ $(CC) $(CFLAGS) -c -o $@ $(srcdir)/$*.c
-
-+%_pic.o: %.c
-+ @rm -f $@
-+ $(CC) -fPIC $(CFLAGS) -c -o $@ $(srcdir)/$*.c
-+
- PSRC = pcap-@V_PCAP@.c
- FSRC = fad-@V_FINDALLDEVS@.c
- SSRC = @SSRC@
-@@ -84,6 +99,7 @@
- # We would like to say "OBJ = $(SRC:.c=.o)" but Ultrix's make cannot
- # hack the extra indirection
- OBJ = $(PSRC:.c=.o) $(FSRC:.c=.o) $(CSRC:.c=.o) $(SSRC:.c=.o) $(GENSRC:.c=.o) $(LIBOBJS)
-+OBJ_PIC = $(PSRC:.c=_pic.o) $(FSRC:.c=_pic.o) $(CSRC:.c=_pic.o) $(SSRC:.c=_pic.o) $(GENSRC:.c=_pic.o)
- HDR = pcap.h pcap-int.h pcap-namedb.h pcap-nit.h pcap-pf.h \
- ethertype.h gencode.h gnuc.h
- GENHDR = \
-@@ -95,15 +111,23 @@
- TAGFILES = \
- $(SRC) $(HDR) $(TAGHDR)
-
--CLEANFILES = $(OBJ) libpcap.a $(GENSRC) $(GENHDR) lex.yy.c
-+CLEANFILES = $(OBJ) $(OBJ_PIC) libpcap.a $(GENSRC) $(GENHDR) lex.yy.c libpcap.so*
-
--all: libpcap.a
-+all: libpcap.a $(SHAREDLIB)
-
- libpcap.a: $(OBJ)
- @rm -f $@
- ar rc $@ $(OBJ) $(LIBS)
- $(RANLIB) $@
-
-+$(SHAREDLIB): $(OBJ_PIC)
-+ -@rm -f $@
-+ -@rm -f $(SOLIBRARY) $(SOLIBRARY).$(MAJ)
-+ $(CC) $(CFLAGS_SHARED) -o $(SHAREDLIB) $(OBJ_PIC) -lc
-+ ln -s $(SHAREDLIB) $(SOLIBRARY).$(MAJ)
-+ ln -s $(SOLIBRARY).$(MAJ) $(SOLIBRARY)
-+
-+
- shared: libpcap.$(DYEXT)
-
- #
-@@ -129,6 +153,10 @@
- scanner.o: scanner.c tokdefs.h
- $(CC) $(CFLAGS) -c scanner.c
-
-+scanner_pic.o: scanner.c tokdefs.h
-+ $(CC) -fPIC $(CFLAGS) -o $@ -c scanner.c
-+
-+
- pcap.o: version.h
-
- tokdefs.h: grammar.c
-@@ -142,9 +170,16 @@
- @rm -f $@
- $(CC) $(CFLAGS) -Dyylval=pcap_lval -c grammar.c
-
-+grammar_pic.o: grammar.c
-+ @rm -f $@
-+ $(CC) -fPIC $(CFLAGS) -Dyylval=pcap_lval -o $@ -c grammar.c
-+
- version.o: version.c
- $(CC) $(CFLAGS) -c version.c
-
-+version_pic.o: version.c
-+ $(CC) -fPIC $(CFLAGS) -c version.c -o $@
-+
- snprintf.o: $(srcdir)/missing/snprintf.c
- $(CC) $(CFLAGS) -o $@ -c $(srcdir)/missing/snprintf.c
-
-@@ -170,10 +205,17 @@
- bpf_filter.o: bpf_filter.c
- $(CC) $(CFLAGS) -c bpf_filter.c
-
-+bpf_filter_pic.o: bpf_filter.c
-+ $(CC) -fPIC $(CFLAGS) -c bpf_filter.c -o $@
-+
-+
- install: libpcap.a
- [ -d $(DESTDIR)$(libdir) ] || \
- (mkdir -p $(DESTDIR)$(libdir); chmod 755 $(DESTDIR)$(libdir))
- $(INSTALL_DATA) libpcap.a $(DESTDIR)$(libdir)/libpcap.a
-+ $(INSTALL_DATA) $(SHAREDLIB) $(DESTDIR)$(libdir)/
-+ ln -sf $(SHAREDLIB) $(DESTDIR)$(libdir)/$(SOLIBRARY).$(MAJ)
-+ ln -sf $(SOLIBRARY).$(MAJ) $(DESTDIR)$(libdir)/$(SOLIBRARY)
- $(RANLIB) $(DESTDIR)$(libdir)/libpcap.a
- [ -d $(DESTDIR)$(includedir) ] || \
- (mkdir -p $(DESTDIR)$(includedir); chmod 755 $(DESTDIR)$(includedir))
diff --git a/openwrt/package/libpcap/patches/101-cross-compile-fix.patch b/openwrt/package/libpcap/patches/101-cross-compile-fix.patch
deleted file mode 100644
index 5ba78adaef..0000000000
--- a/openwrt/package/libpcap/patches/101-cross-compile-fix.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -urN libpcap-0.9.4.orig/Makefile.in libpcap-0.9.4/Makefile.in
---- libpcap-0.9.4.orig/Makefile.in 2006-02-05 16:57:16.000000000 +0100
-+++ libpcap-0.9.4/Makefile.in 2006-02-05 16:57:03.000000000 +0100
-@@ -117,7 +117,7 @@
-
- libpcap.a: $(OBJ)
- @rm -f $@
-- ar rc $@ $(OBJ) $(LIBS)
-+ $(AR) rc $@ $(OBJ) $(LIBS)
- $(RANLIB) $@
-
- $(SHAREDLIB): $(OBJ_PIC)
diff --git a/openwrt/package/libpcap/patches/102-alt-ether.patch b/openwrt/package/libpcap/patches/102-alt-ether.patch
deleted file mode 100644
index 347265d6e9..0000000000
--- a/openwrt/package/libpcap/patches/102-alt-ether.patch
+++ /dev/null
@@ -1,40 +0,0 @@
-diff -urN libpcap-0.9.4.orig/nametoaddr.c libpcap-0.9.4/nametoaddr.c
---- libpcap-0.9.4.orig/nametoaddr.c 2005-04-20 13:13:51.000000000 +0200
-+++ libpcap-0.9.4/nametoaddr.c 2006-02-05 16:58:46.000000000 +0100
-@@ -410,7 +410,7 @@
- e = ep = (u_char *)malloc(6);
-
- while (*s) {
-- if (*s == ':')
-+ if (*s == ':' || *s == '.')
- s += 1;
- d = xdtoi(*s++);
- if (isxdigit((unsigned char)*s)) {
-diff -urN libpcap-0.9.4.orig/scanner.l libpcap-0.9.4/scanner.l
---- libpcap-0.9.4.orig/scanner.l 2005-09-05 11:08:07.000000000 +0200
-+++ libpcap-0.9.4/scanner.l 2006-02-05 17:00:13.000000000 +0100
-@@ -80,6 +80,7 @@
- N ([0-9]+|(0X|0x)[0-9A-Fa-f]+)
- B ([0-9A-Fa-f][0-9A-Fa-f]?)
- W ([0-9A-Fa-f][0-9A-Fa-f]?[0-9A-Fa-f]?[0-9A-Fa-f]?)
-+X [0-9A-Fa-f]
-
- %a 16000
- %o 19000
-@@ -306,7 +307,7 @@
- {N} { yylval.i = stoi((char *)yytext); return NUM; }
- ({N}\.{N})|({N}\.{N}\.{N})|({N}\.{N}\.{N}\.{N}) {
- yylval.s = sdup((char *)yytext); return HID; }
--{B}:{B}:{B}:{B}:{B}:{B} { yylval.e = pcap_ether_aton((char *)yytext);
-+({B}:{B}:{B}:{B}:{B}:{B})|({B}\.{B}\.{B}\.{B}\.{B}\.{B}) { yylval.e = pcap_ether_aton((char *)yytext);
- return EID; }
- {V6} {
- #ifdef INET6
-@@ -324,6 +325,7 @@
- #endif /*INET6*/
- }
- {B}:+({B}:+)+ { bpf_error("bogus ethernet address %s", yytext); }
-+{X}{12} { yylval.e = pcap_ether_aton((char *)yytext); return EID;}
- icmptype { yylval.i = 0; return NUM; }
- icmpcode { yylval.i = 1; return NUM; }
- icmp-echoreply { yylval.i = 0; return NUM; }