aboutsummaryrefslogtreecommitdiffstats
path: root/openwrt/package/ipset
diff options
context:
space:
mode:
Diffstat (limited to 'openwrt/package/ipset')
-rw-r--r--openwrt/package/ipset/Config.in9
-rw-r--r--openwrt/package/ipset/Makefile34
-rw-r--r--openwrt/package/ipset/ipkg/ipset.control5
-rw-r--r--openwrt/package/ipset/patches/kernel26.patch66
4 files changed, 0 insertions, 114 deletions
diff --git a/openwrt/package/ipset/Config.in b/openwrt/package/ipset/Config.in
deleted file mode 100644
index 293292cfea..0000000000
--- a/openwrt/package/ipset/Config.in
+++ /dev/null
@@ -1,9 +0,0 @@
-config BR2_PACKAGE_IPSET
- prompt "ipset............................. Netfilter ip sets administration utility"
- tristate
- default m if CONFIG_DEVEL
- help
- Netfilter ip sets administration utility
-
- http://ipset.netfilter.org/
-
diff --git a/openwrt/package/ipset/Makefile b/openwrt/package/ipset/Makefile
deleted file mode 100644
index 8369b29bfd..0000000000
--- a/openwrt/package/ipset/Makefile
+++ /dev/null
@@ -1,34 +0,0 @@
-# $Id$
-#
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=ipset
-PKG_VERSION:=2.2.3
-PKG_RELEASE:=1
-PKG_MD5SUM:=1709424cc2cdb925d4fb6fd5fcaefc26
-
-PKG_SOURCE_URL:=http://ipset.netfilter.org
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-20050914.tar.bz2
-PKG_BUILD_DIR:=$(BUILD_DIR)/ipset-$(PKG_VERSION)
-PKG_CAT:=bzcat
-
-include $(TOPDIR)/package/rules.mk
-
-$(eval $(call PKG_template,IPSET,$(PKG_NAME),$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-
-$(PKG_BUILD_DIR)/.configured:
- touch $@
-
-$(PKG_BUILD_DIR)/.built:
- $(MAKE) -C $(PKG_BUILD_DIR) \
- CC=$(TARGET_CC) LD=$(TARGET_CROSS)ld \
- CFLAGS="$(TARGET_CFLAGS) -Wall -I$(LINUX_DIR)/include -I." \
- KERNEL_DIR=$(LINUX_DIR) PREFIX=/usr
- touch $@
-
-$(IPKG_IPSET):
- $(MAKE) -C $(PKG_BUILD_DIR) \
- DESTDIR=$(IDIR_IPSET) PREFIX=/usr install
- rm -rf $(IDIR_IPSET)/usr/man
- $(IPKG_BUILD) $(IDIR_IPSET) $(PACKAGE_DIR)
-
diff --git a/openwrt/package/ipset/ipkg/ipset.control b/openwrt/package/ipset/ipkg/ipset.control
deleted file mode 100644
index f7f6ae0e63..0000000000
--- a/openwrt/package/ipset/ipkg/ipset.control
+++ /dev/null
@@ -1,5 +0,0 @@
-Package: ipset
-Priority: optional
-Section: net
-Description: Netfilter ip sets administration utility
-Depends: kmod-iptables-extra
diff --git a/openwrt/package/ipset/patches/kernel26.patch b/openwrt/package/ipset/patches/kernel26.patch
deleted file mode 100644
index 46112ab25f..0000000000
--- a/openwrt/package/ipset/patches/kernel26.patch
+++ /dev/null
@@ -1,66 +0,0 @@
-diff -Nur ipset-2.2.3.orig/ipset.c ipset-2.2.3/ipset.c
---- ipset-2.2.3.orig/ipset.c 2005-04-05 09:56:02.000000000 +0200
-+++ ipset-2.2.3/ipset.c 2005-09-29 13:07:07.446923250 +0200
-@@ -21,7 +21,6 @@
- #include <stdarg.h>
- #include <netdb.h>
- #include <dlfcn.h>
--#include <asm/bitops.h>
-
- #include "ipset.h"
-
-diff -Nur ipset-2.2.3.orig/ipset_iphash.c ipset-2.2.3/ipset_iphash.c
---- ipset-2.2.3.orig/ipset_iphash.c 2005-01-19 14:38:57.000000000 +0100
-+++ ipset-2.2.3/ipset_iphash.c 2005-09-29 13:07:26.308102000 +0200
-@@ -25,7 +25,6 @@
- #include <sys/types.h>
- #include <netinet/in.h>
- #include <arpa/inet.h>
--#include <asm/bitops.h>
- #include <asm/types.h>
-
- #include <linux/netfilter_ipv4/ip_set_iphash.h>
-diff -Nur ipset-2.2.3.orig/ipset_ipmap.c ipset-2.2.3/ipset_ipmap.c
---- ipset-2.2.3.orig/ipset_ipmap.c 2005-01-19 14:38:57.000000000 +0100
-+++ ipset-2.2.3/ipset_ipmap.c 2005-09-29 13:07:07.446923250 +0200
-@@ -22,7 +22,6 @@
- #include <sys/socket.h>
- #include <netinet/in.h>
- #include <arpa/inet.h>
--#include <asm/bitops.h>
-
- #include <linux/netfilter_ipv4/ip_set_ipmap.h>
- #include "ipset.h"
-diff -Nur ipset-2.2.3.orig/ipset_macipmap.c ipset-2.2.3/ipset_macipmap.c
---- ipset-2.2.3.orig/ipset_macipmap.c 2005-01-19 14:38:57.000000000 +0100
-+++ ipset-2.2.3/ipset_macipmap.c 2005-09-29 13:07:07.446923250 +0200
-@@ -24,7 +24,6 @@
- #include <sys/socket.h>
- #include <netinet/in.h>
- #include <arpa/inet.h>
--#include <asm/bitops.h>
- #include <linux/if_ether.h>
-
- #include <linux/netfilter_ipv4/ip_set_macipmap.h>
-diff -Nur ipset-2.2.3.orig/ipset_nethash.c ipset-2.2.3/ipset_nethash.c
---- ipset-2.2.3.orig/ipset_nethash.c 2005-05-09 07:44:25.000000000 +0200
-+++ ipset-2.2.3/ipset_nethash.c 2005-09-29 13:07:07.446923250 +0200
-@@ -25,7 +25,6 @@
- #include <sys/types.h>
- #include <netinet/in.h>
- #include <arpa/inet.h>
--#include <asm/bitops.h>
- #include <asm/types.h>
-
- #include <linux/netfilter_ipv4/ip_set_nethash.h>
-diff -Nur ipset-2.2.3.orig/ipset_portmap.c ipset-2.2.3/ipset_portmap.c
---- ipset-2.2.3.orig/ipset_portmap.c 2005-01-19 14:38:57.000000000 +0100
-+++ ipset-2.2.3/ipset_portmap.c 2005-09-29 13:07:07.446923250 +0200
-@@ -21,7 +21,6 @@
- #include <sys/socket.h>
- #include <netinet/in.h>
- #include <arpa/inet.h>
--#include <asm/bitops.h>
-
- #include <linux/netfilter_ipv4/ip_set_portmap.h>
- #include "ipset.h"