aboutsummaryrefslogtreecommitdiffstats
path: root/openwrt/package/howl
diff options
context:
space:
mode:
Diffstat (limited to 'openwrt/package/howl')
-rw-r--r--openwrt/package/howl/Config.in62
-rw-r--r--openwrt/package/howl/Makefile122
-rw-r--r--openwrt/package/howl/files/autoipd.init20
-rw-r--r--openwrt/package/howl/files/mDNSResponder.conf2
-rw-r--r--openwrt/package/howl/files/mDNSResponder.init20
-rw-r--r--openwrt/package/howl/files/nifd.init21
-rw-r--r--openwrt/package/howl/ipkg/autoipd.control5
-rw-r--r--openwrt/package/howl/ipkg/howl-utils.control5
-rw-r--r--openwrt/package/howl/ipkg/libhowl.control4
-rw-r--r--openwrt/package/howl/ipkg/mdnsresponder.conffiles1
-rw-r--r--openwrt/package/howl/ipkg/mdnsresponder.control5
-rw-r--r--openwrt/package/howl/ipkg/nifd.control5
-rw-r--r--openwrt/package/howl/patches/config-path.patch14
-rw-r--r--openwrt/package/howl/patches/debug-log.patch10
-rw-r--r--openwrt/package/howl/patches/proto-fix.patch11
15 files changed, 0 insertions, 307 deletions
diff --git a/openwrt/package/howl/Config.in b/openwrt/package/howl/Config.in
deleted file mode 100644
index a409dd2a64..0000000000
--- a/openwrt/package/howl/Config.in
+++ /dev/null
@@ -1,62 +0,0 @@
-menu "howl.............................. A Zeroconf networking implementation"
-
-config BR2_COMPILE_HOWL
- tristate
- default n
- depends BR2_PACKAGE_LIBHOWL
-
-config BR2_PACKAGE_LIBHOWL
- prompt "libhowl........................... The howl library"
- tristate
- default m if CONFIG_DEVEL
- select BR2_COMPILE_HOWL
- help
- A cross-platform implementation of Zeroconf networking.
-
- http://www.porchdogsoft.com/products/howl/
-
- This package contains shared libraries, needed by other programs.
-
-config BR2_PACKAGE_HOWL_UTILS
- prompt "howl-utils...................... The howl client utilities"
- tristate
- default m if CONFIG_DEVEL
- depends BR2_PACKAGE_LIBHOWL
- help
- A cross-platform implementation of Zeroconf networking.
-
- http://www.porchdogsoft.com/products/howl/
-
-comment "Daemons ---"
-
-config BR2_PACKAGE_AUTOIPD
- prompt "autoipd........................... An IPv4 Link-Local address self-assigner daemon"
- tristate
- default m if CONFIG_DEVEL
- select BR2_PACKAGE_LIBHOWL
- help
- A cross-platform implementation of Zeroconf networking.
-
- http://www.porchdogsoft.com/products/howl/
-
-config BR2_PACKAGE_MDNSRESPONDER
- prompt "mdnsresponder..................... An mDNS (Multicast DNS) service responder daemon"
- tristate
- default m if CONFIG_DEVEL
- select BR2_PACKAGE_LIBHOWL
- help
- A cross-platform implementation of Zeroconf networking.
-
- http://www.porchdogsoft.com/products/howl/
-
-config BR2_PACKAGE_NIFD
- prompt "nifd.............................. A network interface monitor daemon"
- tristate
- default m if CONFIG_DEVEL
- select BR2_PACKAGE_LIBHOWL
- help
- A cross-platform implementation of Zeroconf networking.
-
- http://www.porchdogsoft.com/products/howl/
-
-endmenu
diff --git a/openwrt/package/howl/Makefile b/openwrt/package/howl/Makefile
deleted file mode 100644
index 32557c5f18..0000000000
--- a/openwrt/package/howl/Makefile
+++ /dev/null
@@ -1,122 +0,0 @@
-# $Id$
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=howl
-PKG_VERSION:=1.0.0
-PKG_RELEASE:=1
-PKG_MD5SUM:=c389d3ffba0e69a179de2ec650f1fdcc
-
-PKG_SOURCE_URL:=http://www.porchdogsoft.com/download/
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
-
-include $(TOPDIR)/package/rules.mk
-
-$(eval $(call PKG_template,LIBHOWL,libhowl,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-$(eval $(call PKG_template,MDNSRESPONDER,mdnsresponder,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-$(eval $(call PKG_template,HOWL_UTILS,howl-utils,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-$(eval $(call PKG_template,AUTOIPD,autoipd,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-$(eval $(call PKG_template,NIFD,nifd,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-
-$(PKG_BUILD_DIR)/.configured:
- (cd $(PKG_BUILD_DIR); rm -rf config.{cache,status} ; \
- $(TARGET_CONFIGURE_OPTS) \
- CFLAGS="$(TARGET_CFLAGS)" \
- CPPFLAGS="-I$(STAGING_DIR)/usr/include" \
- LDFLAGS="-L$(STAGING_DIR)/usr/lib" \
- ./configure \
- --target=$(GNU_TARGET_NAME) \
- --host=$(GNU_TARGET_NAME) \
- --build=$(GNU_HOST_NAME) \
- --program-prefix="" \
- --program-suffix="" \
- --prefix=/usr \
- --exec-prefix=/usr \
- --bindir=/usr/bin \
- --datadir=/usr/share \
- --includedir=/usr/include \
- --infodir=/usr/share/info \
- --libdir=/usr/lib \
- --libexecdir=/usr/lib \
- --localstatedir=/var \
- --mandir=/usr/share/man \
- --sbindir=/usr/sbin \
- --sysconfdir=/etc \
- $(DISABLE_LARGEFILE) \
- $(DISABLE_NLS) \
- --enable-shared \
- --enable-static \
- )
- touch $@
-
-$(PKG_BUILD_DIR)/.built:
- rm -rf $(PKG_INSTALL_DIR)
- mkdir -p $(PKG_INSTALL_DIR)
- $(MAKE) -C $(PKG_BUILD_DIR) \
- DESTDIR="$(PKG_INSTALL_DIR)" \
- all install
- touch $@
-
-$(IPKG_LIBHOWL):
- install -m0755 -d $(IDIR_LIBHOWL)/usr/lib
- $(CP) $(PKG_INSTALL_DIR)/usr/lib/lib{howl,mDNSResponder}.so.* $(IDIR_LIBHOWL)/usr/lib/
- $(RSTRIP) $(IDIR_LIBHOWL)
- $(IPKG_BUILD) $(IDIR_LIBHOWL) $(PACKAGE_DIR)
-
-$(IPKG_HOWL_UTILS):
- install -m0755 -d $(IDIR_HOWL_UTILS)/usr/bin
- $(CP) $(PKG_INSTALL_DIR)/usr/bin/mDNS{Browse,Publish,Query,Resolve} $(IDIR_HOWL_UTILS)/usr/bin/
- $(RSTRIP) $(IDIR_HOWL_UTILS)
- $(IPKG_BUILD) $(IDIR_HOWL_UTILS) $(PACKAGE_DIR)
-
-$(IPKG_MDNSRESPONDER):
- install -m0755 -d $(IDIR_MDNSRESPONDER)/etc
- install -m0644 ./files/mDNSResponder.conf $(IDIR_MDNSRESPONDER)/etc/mDNSResponder.conf
- install -m0755 -d $(IDIR_MDNSRESPONDER)/etc/init.d
- install -m0644 ./files/mDNSResponder.init $(IDIR_MDNSRESPONDER)/etc/init.d/mDNSResponder
- install -m0755 -d $(IDIR_MDNSRESPONDER)/usr/sbin
- $(CP) $(PKG_INSTALL_DIR)/usr/bin/mDNSResponder $(IDIR_MDNSRESPONDER)/usr/sbin/
- $(RSTRIP) $(IDIR_MDNSRESPONDER)
- $(IPKG_BUILD) $(IDIR_MDNSRESPONDER) $(PACKAGE_DIR)
-
-$(IPKG_AUTOIPD):
- install -m0755 -d $(IDIR_AUTOIPD)/etc/init.d
- install -m0644 ./files/autoipd.init $(IDIR_AUTOIPD)/etc/init.d/autoipd
- install -m0755 -d $(IDIR_AUTOIPD)/usr/sbin
- $(CP) $(PKG_INSTALL_DIR)/usr/bin/autoipd $(IDIR_AUTOIPD)/usr/sbin/
- $(RSTRIP) $(IDIR_AUTOIPD)
- $(IPKG_BUILD) $(IDIR_AUTOIPD) $(PACKAGE_DIR)
-
-$(IPKG_NIFD):
- install -m0755 -d $(IDIR_NIFD)/etc/init.d
- install -m0644 ./files/nifd.init $(IDIR_NIFD)/etc/init.d/nifd
- install -m0755 -d $(IDIR_NIFD)/usr/sbin
- $(CP) $(PKG_INSTALL_DIR)/usr/bin/nifd $(IDIR_NIFD)/usr/sbin/
- $(RSTRIP) $(IDIR_NIFD)
- $(IPKG_BUILD) $(IDIR_NIFD) $(PACKAGE_DIR)
-
-$(STAGING_DIR)/usr/lib/libhowl.so: $(PKG_BUILD_DIR)/.built
- mkdir -p $(STAGING_DIR)/usr/include
- $(CP) $(PKG_INSTALL_DIR)/usr/include/howl $(STAGING_DIR)/usr/include/
- mkdir -p $(STAGING_DIR)/usr/lib
- $(CP) $(PKG_INSTALL_DIR)/usr/lib/lib{howl,mDNSResponder}.{a,so*} $(STAGING_DIR)/usr/lib/
- mkdir -p $(STAGING_DIR)/usr/lib/pkgconfig
- $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/howl.pc $(STAGING_DIR)/usr/lib/pkgconfig/
- $(SED) 's,-I/usr/include/howl,,g' $(STAGING_DIR)/usr/lib/pkgconfig/howl.pc
- $(SED) 's,-L/usr/lib,,g' $(STAGING_DIR)/usr/lib/pkgconfig/howl.pc
- touch $@
-
-install-dev: $(STAGING_DIR)/usr/lib/libhowl.so
-
-uninstall-dev:
- rm -rf \
- $(STAGING_DIR)/usr/include/howl \
- $(STAGING_DIR)/usr/lib/lib{howl,mDNSResponder}.{a,so*} \
- $(STAGING_DIR)/usr/lib/pkgconfig/howl.pc \
-
-compile-targets: install-dev
-clean-targets: uninstall-dev
diff --git a/openwrt/package/howl/files/autoipd.init b/openwrt/package/howl/files/autoipd.init
deleted file mode 100644
index eed593603c..0000000000
--- a/openwrt/package/howl/files/autoipd.init
+++ /dev/null
@@ -1,20 +0,0 @@
-#!/bin/sh
-
-DEFAULT=/etc/default/autopid
-RUN_D=/var/run
-PID_F=$RUN_D/autoipd.pid
-[ -f $DEFAULT ] && . $DEFAULT
-
-case $1 in
- start)
- [ -d $RUN_D ] || mkdir -p $RUN_D
- autoipd $OPTIONS
- ;;
- stop)
- [ -f $PID_F ] && kill $(cat $PID_F)
- ;;
- *)
- echo "usage: $0 (start|stop)"
- exit 1
-esac
-exit $?
diff --git a/openwrt/package/howl/files/mDNSResponder.conf b/openwrt/package/howl/files/mDNSResponder.conf
deleted file mode 100644
index eac712f9e5..0000000000
--- a/openwrt/package/howl/files/mDNSResponder.conf
+++ /dev/null
@@ -1,2 +0,0 @@
-#name #type #domain #port #text
-"My Router" _http._tcp local. 80 "txtvers=1" "path=/P" "note=My Router"
diff --git a/openwrt/package/howl/files/mDNSResponder.init b/openwrt/package/howl/files/mDNSResponder.init
deleted file mode 100644
index 292280f7c1..0000000000
--- a/openwrt/package/howl/files/mDNSResponder.init
+++ /dev/null
@@ -1,20 +0,0 @@
-#!/bin/sh
-
-DEFAULT=/etc/default/mDNSResponder
-RUN_D=/var/run
-PID_F=$RUN_D/mDNSResponder.pid
-[ -f $DEFAULT ] && . $DEFAULT
-
-case $1 in
- start)
- [ -d $RUN_D ] || mkdir -p $RUN_D
- mDNSResponder $OPTIONS
- ;;
- stop)
- [ -f $PID_F ] && kill $(cat $PID_F)
- ;;
- *)
- echo "usage: $0 (start|stop)"
- exit 1
-esac
-exit $?
diff --git a/openwrt/package/howl/files/nifd.init b/openwrt/package/howl/files/nifd.init
deleted file mode 100644
index b67861eb26..0000000000
--- a/openwrt/package/howl/files/nifd.init
+++ /dev/null
@@ -1,21 +0,0 @@
-#!/bin/sh
-
-DEFAULT=/etc/default/nifd
-RUN_D=/var/run
-PID_F=$RUN_D/nifd.pid
-
-[ -f $DEFAULT ] && . $DEFAULT
-
-case $1 in
- start)
- [ -d $RUN_D ] || mkdir -p $RUN_D
- nifd $OPTIONS
- ;;
- stop)
- [ -f $PID_F ] && kill $(cat $PID_F)
- ;;
- *)
- echo "usage: $0 (start|stop)"
- exit 1
-esac
-exit $?
diff --git a/openwrt/package/howl/ipkg/autoipd.control b/openwrt/package/howl/ipkg/autoipd.control
deleted file mode 100644
index 5d8af85e91..0000000000
--- a/openwrt/package/howl/ipkg/autoipd.control
+++ /dev/null
@@ -1,5 +0,0 @@
-Package: autoipd
-Priority: optional
-Section: net
-Description: an IPv4 Link-Local address self-assigner daemon
-Depends: libhowl, libpthread
diff --git a/openwrt/package/howl/ipkg/howl-utils.control b/openwrt/package/howl/ipkg/howl-utils.control
deleted file mode 100644
index ed6695b764..0000000000
--- a/openwrt/package/howl/ipkg/howl-utils.control
+++ /dev/null
@@ -1,5 +0,0 @@
-Package: howl-utils
-Priority: optional
-Section: net
-Description: a ZeroConf (aka RendezVous) implementation (utilities)
-Depends: libhowl, libpthread
diff --git a/openwrt/package/howl/ipkg/libhowl.control b/openwrt/package/howl/ipkg/libhowl.control
deleted file mode 100644
index 390862d5ca..0000000000
--- a/openwrt/package/howl/ipkg/libhowl.control
+++ /dev/null
@@ -1,4 +0,0 @@
-Package: libhowl
-Priority: optional
-Section: net
-Description: a ZeroConf (aka RendezVous) implementation (library)
diff --git a/openwrt/package/howl/ipkg/mdnsresponder.conffiles b/openwrt/package/howl/ipkg/mdnsresponder.conffiles
deleted file mode 100644
index eaf1aead95..0000000000
--- a/openwrt/package/howl/ipkg/mdnsresponder.conffiles
+++ /dev/null
@@ -1 +0,0 @@
-/etc/mDNSResponder.conf
diff --git a/openwrt/package/howl/ipkg/mdnsresponder.control b/openwrt/package/howl/ipkg/mdnsresponder.control
deleted file mode 100644
index e2312e338f..0000000000
--- a/openwrt/package/howl/ipkg/mdnsresponder.control
+++ /dev/null
@@ -1,5 +0,0 @@
-Package: mdnsresponder
-Priority: optional
-Section: net
-Description: an mDNS (Multicast DNS) service responder daemon
-Depends: libhowl, libpthread
diff --git a/openwrt/package/howl/ipkg/nifd.control b/openwrt/package/howl/ipkg/nifd.control
deleted file mode 100644
index 20f47e3f24..0000000000
--- a/openwrt/package/howl/ipkg/nifd.control
+++ /dev/null
@@ -1,5 +0,0 @@
-Package: nifd
-Priority: optional
-Section: net
-Description: a network interface monitor daemon
-Depends: libhowl, libpthread
diff --git a/openwrt/package/howl/patches/config-path.patch b/openwrt/package/howl/patches/config-path.patch
deleted file mode 100644
index a0c26d1e27..0000000000
--- a/openwrt/package/howl/patches/config-path.patch
+++ /dev/null
@@ -1,14 +0,0 @@
---- howl-0.9.10-orig/src/mDNSResponder/Posix/posix_main.c 2005-01-27 04:11:20.000000000 +0100
-+++ howl-0.9.10-2/src/mDNSResponder/Posix/posix_main.c 2005-03-19 13:04:42.000000000 +0100
-@@ -249,9 +249,9 @@
- {
- sw_mdns_servant_load_file(servant, conf_file);
- }
-- else if (sw_mdns_servant_load_file(servant, "/etc/howl/mDNSResponder.conf") != SW_OKAY)
-+ else
- {
-- sw_mdns_servant_load_file(servant, "/usr/local/etc/howl/mDNSResponder.conf");
-+ sw_mdns_servant_load_file(servant, "/etc/mDNSResponder.conf");
- }
-
- write_pidfile("mDNSResponder", &pidfd);
diff --git a/openwrt/package/howl/patches/debug-log.patch b/openwrt/package/howl/patches/debug-log.patch
deleted file mode 100644
index 91410b8e94..0000000000
--- a/openwrt/package/howl/patches/debug-log.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- howl-0.9.10-orig/src/mDNSResponder/Posix/posix_main.c 2005-01-27 04:11:20.000000000 +0100
-+++ howl-0.9.10-2/src/mDNSResponder/Posix/posix_main.c 2005-03-19 13:04:42.000000000 +0100
-@@ -186,6 +186,7 @@
- case 'd':
- {
- make_daemon = SW_FALSE;
-+ sw_debug_set_level(SW_LOG_VERBOSE);
- }
- break;
-
diff --git a/openwrt/package/howl/patches/proto-fix.patch b/openwrt/package/howl/patches/proto-fix.patch
deleted file mode 100644
index 0b9d105dd6..0000000000
--- a/openwrt/package/howl/patches/proto-fix.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- howl-0.9.10-orig/include/salt/platform.h 2005-01-28 21:46:14.000000000 +0100
-+++ howl-0.9.10-2/include/salt/platform.h 2005-03-19 13:04:42.000000000 +0100
-@@ -409,7 +409,7 @@
- */
-
- sw_const_string
--sw_strerror();
-+sw_strerror(void);
-
-
- /*