aboutsummaryrefslogtreecommitdiffstats
path: root/openwrt/package/frickin
diff options
context:
space:
mode:
Diffstat (limited to 'openwrt/package/frickin')
-rw-r--r--openwrt/package/frickin/Config.in11
-rw-r--r--openwrt/package/frickin/Makefile39
-rw-r--r--openwrt/package/frickin/files/frickin.default16
-rw-r--r--openwrt/package/frickin/files/frickin.init16
-rw-r--r--openwrt/package/frickin/ipkg/frickin.conffiles1
-rw-r--r--openwrt/package/frickin/ipkg/frickin.control4
6 files changed, 0 insertions, 87 deletions
diff --git a/openwrt/package/frickin/Config.in b/openwrt/package/frickin/Config.in
deleted file mode 100644
index b118a111a4..0000000000
--- a/openwrt/package/frickin/Config.in
+++ /dev/null
@@ -1,11 +0,0 @@
-config BR2_PACKAGE_FRICKIN
- prompt "frickin........................... PPTP (Point-to-Point Tunneling Protocol) proxy"
- tristate
- default m if CONFIG_DEVEL
- help
- Frickin PPTP Proxy allows a Point-to-Point Tunneling Protocol (PPTP)
- client to connect to a PPTP server through Network Address
- Translation (NAT).
-
- http://frickin.sourceforge.net/
-
diff --git a/openwrt/package/frickin/Makefile b/openwrt/package/frickin/Makefile
deleted file mode 100644
index a527209193..0000000000
--- a/openwrt/package/frickin/Makefile
+++ /dev/null
@@ -1,39 +0,0 @@
-# $Id$
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=frickin
-PKG_VERSION:=1.3
-PKG_RELEASE:=1
-PKG_MD5SUM:= 5b2e98da2310c71c703d4617b88a173f
-
-PKG_SOURCE_URL:=@SF/frickin
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
-
-include $(TOPDIR)/package/rules.mk
-
-$(eval $(call PKG_template,FRICKIN,frickin,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-
-$(PKG_BUILD_DIR)/.configured:
- touch $@
-
-$(PKG_BUILD_DIR)/.built:
- $(MAKE) -C $(PKG_BUILD_DIR) \
- $(TARGET_CONFIGURE_OPTS) \
- CFLAGS="$(TARGET_CFLAGS)" \
- all
- touch $@
-
-$(IPKG_FRICKIN):
- install -d -m0755 $(IDIR_FRICKIN)/etc/default
- install -m0644 ./files/frickin.default $(IDIR_FRICKIN)/etc/default/frickin
- install -d -m0755 $(IDIR_FRICKIN)/etc/init.d
- install -m0755 ./files/frickin.init $(IDIR_FRICKIN)/etc/init.d/frickin
- install -d -m0755 $(IDIR_FRICKIN)/usr/sbin
- install -m0755 $(PKG_BUILD_DIR)/frickin $(IDIR_FRICKIN)/usr/sbin/
- $(RSTRIP) $(IDIR_FRICKIN)
- $(IPKG_BUILD) $(IDIR_FRICKIN) $(PACKAGE_DIR)
diff --git a/openwrt/package/frickin/files/frickin.default b/openwrt/package/frickin/files/frickin.default
deleted file mode 100644
index 9f55d5bad2..0000000000
--- a/openwrt/package/frickin/files/frickin.default
+++ /dev/null
@@ -1,16 +0,0 @@
-# ip address of the server the proxy should connect to
-TARGET_IP=192.168.1.2
-
-# ip address the proxy should listen to for incoming connections
-#LISTEN_IP=192.168.1.1
-
-# maximum number of simultaneous connections
-#PROXY_CONN_MAX=20
-
-# user the proxy should run as
-#PROXY_USER=root
-
-[ -n "$TARGET_IP" ] && OPTIONS="$OPTIONS -s $TARGET_IP"
-[ -n "$LISTEN_IP" ] && OPTIONS="$OPTIONS -l $LISTEN_IP"
-[ -n "$PROXY_CONN_MAX" ] && OPTIONS="$OPTIONS -c $PROXY_CONN_MAX"
-[ -n "$PROXY_USER" ] && OPTIONS="$OPTIONS -u $PROXY_USER"
diff --git a/openwrt/package/frickin/files/frickin.init b/openwrt/package/frickin/files/frickin.init
deleted file mode 100644
index e07a0945b6..0000000000
--- a/openwrt/package/frickin/files/frickin.init
+++ /dev/null
@@ -1,16 +0,0 @@
-#!/bin/sh
-
-BIN=frickin
-DEFAULT=/etc/default/$BIN
-[ -f $DEFAULT ] && . $DEFAULT
-
-case $1 in
- start)
- $BIN $OPTIONS &
- ;;
- *)
- echo "usage: $0 (start)"
- exit 1
-esac
-
-exit $?
diff --git a/openwrt/package/frickin/ipkg/frickin.conffiles b/openwrt/package/frickin/ipkg/frickin.conffiles
deleted file mode 100644
index f374430c3b..0000000000
--- a/openwrt/package/frickin/ipkg/frickin.conffiles
+++ /dev/null
@@ -1 +0,0 @@
-/etc/default/frickin
diff --git a/openwrt/package/frickin/ipkg/frickin.control b/openwrt/package/frickin/ipkg/frickin.control
deleted file mode 100644
index a8b3fb4f0e..0000000000
--- a/openwrt/package/frickin/ipkg/frickin.control
+++ /dev/null
@@ -1,4 +0,0 @@
-Package: frickin
-Priority: optional
-Section: net
-Description: PPTP (Point-to-Point Tunneling Protocol) proxy