aboutsummaryrefslogtreecommitdiffstats
path: root/openwrt/package/dnsmasq
diff options
context:
space:
mode:
Diffstat (limited to 'openwrt/package/dnsmasq')
-rw-r--r--openwrt/package/dnsmasq/Config.in10
-rw-r--r--openwrt/package/dnsmasq/Makefile36
-rw-r--r--openwrt/package/dnsmasq/files/dnsmasq.conf29
-rw-r--r--openwrt/package/dnsmasq/files/dnsmasq.init45
-rw-r--r--openwrt/package/dnsmasq/ipkg/dnsmasq.conffiles1
-rw-r--r--openwrt/package/dnsmasq/ipkg/dnsmasq.control4
-rw-r--r--openwrt/package/dnsmasq/patches/101-ipv6.patch13
7 files changed, 0 insertions, 138 deletions
diff --git a/openwrt/package/dnsmasq/Config.in b/openwrt/package/dnsmasq/Config.in
deleted file mode 100644
index b20bf73620..0000000000
--- a/openwrt/package/dnsmasq/Config.in
+++ /dev/null
@@ -1,10 +0,0 @@
-config BR2_PACKAGE_DNSMASQ
- prompt "dnsmasq........................... Lightweight DNS and DHCP server"
- tristate
- default y
- help
- A lightweight DNS and DHCP server. It is intended to provide
- coupled DNS and DHCP service to a LAN.
-
- http://www.thekelleys.org.uk/dnsmasq/
-
diff --git a/openwrt/package/dnsmasq/Makefile b/openwrt/package/dnsmasq/Makefile
deleted file mode 100644
index 88bd9f21b9..0000000000
--- a/openwrt/package/dnsmasq/Makefile
+++ /dev/null
@@ -1,36 +0,0 @@
-# $Id$
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=dnsmasq
-PKG_VERSION:=2.27
-PKG_RELEASE:=1
-PKG_MD5SUM:=489198ec87101087043adc98bbe062dc
-
-PKG_SOURCE_URL:=http://thekelleys.org.uk/dnsmasq
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_CAT:=zcat
-
-include $(TOPDIR)/package/rules.mk
-
-$(eval $(call PKG_template,DNSMASQ,$(PKG_NAME),$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-
-$(PKG_BUILD_DIR)/.configured:
- touch $@
-
-$(PKG_BUILD_DIR)/.built:
- $(MAKE) -C $(PKG_BUILD_DIR) \
- CC=$(TARGET_CC) CFLAGS="$(TARGET_CFLAGS)" \
- BINDIR=/usr/sbin MANDIR=/usr/man
- touch $@
-
-$(IPKG_DNSMASQ):
- install -d -m0755 $(IDIR_DNSMASQ)/usr/sbin
- $(CP) $(PKG_BUILD_DIR)/src/$(PKG_NAME) $(IDIR_DNSMASQ)/usr/sbin/
- $(STRIP) $(IDIR_DNSMASQ)/usr/sbin/*
- install -d -m0755 $(IDIR_DNSMASQ)/etc/init.d/
- install -m0644 ./files/dnsmasq.conf $(IDIR_DNSMASQ)/etc/dnsmasq.conf
- install -m0755 ./files/dnsmasq.init $(IDIR_DNSMASQ)/etc/init.d/S50dnsmasq
- $(IPKG_BUILD) $(IDIR_DNSMASQ) $(PACKAGE_DIR)
-
diff --git a/openwrt/package/dnsmasq/files/dnsmasq.conf b/openwrt/package/dnsmasq/files/dnsmasq.conf
deleted file mode 100644
index 7aed3a3da4..0000000000
--- a/openwrt/package/dnsmasq/files/dnsmasq.conf
+++ /dev/null
@@ -1,29 +0,0 @@
-# filter what we send upstream
-domain-needed
-bogus-priv
-filterwin2k
-localise-queries
-
-# allow /etc/hosts and dhcp lookups via *.lan
-local=/lan/
-domain=lan
-expand-hosts
-
-@ifdef dhcp_enable
-dhcp-range=@@start@@,@@end@@,@@netmask@@,@@lease@@
-@endif
-@ifdef wan_ifname
-except-interface=@@wan_ifname@@
-@endif
-
-# enable dhcp (start,end,netmask,leasetime)
-dhcp-authoritative
-dhcp-leasefile=/tmp/dhcp.leases
-
-# use /etc/ethers for static hosts; same format as --dhcp-host
-# <hwaddr> <ipaddr>
-read-ethers
-
-# other useful options:
-# default route(s): dhcp-option=3,192.168.1.1,192.168.1.2
-# dns server(s): dhcp-option=6,192.168.1.1,192.168.1.2
diff --git a/openwrt/package/dnsmasq/files/dnsmasq.init b/openwrt/package/dnsmasq/files/dnsmasq.init
deleted file mode 100644
index 17ef43c3d5..0000000000
--- a/openwrt/package/dnsmasq/files/dnsmasq.init
+++ /dev/null
@@ -1,45 +0,0 @@
-#!/bin/sh
-. /etc/config/network
-
-# The following is to automatically configure the DHCP settings
-# based on config settings. Feel free to replace all this crap
-# with a simple "dnsmasq" and manage everything via the
-# /etc/dnsmasq.conf config file
-
-[ -f /etc/dnsmasq.conf ] || exit
-
-args=""
-iface=lan
-eval "ifname=\${${iface}_ifname}"
-
-dhcp_enable="${dhcp_enable:-1}"
-dhcp_start="${dhcp_start:-100}"
-dhcp_num="${dhcp_num:-50}"
-dhcp_lease="${dhcp_lease:-12h}"
-
-# if dhcp_enable is unset and there is a dhcp server on the network already, default to dhcp_enable=0
-[ -z "$dhcp_enable" ] && udhcpc -n -q -R -s /bin/true -i $ifname >&- && dhcp_enable="${dhcp_enable:-0}"
-
-# dhcp_enable=0 disables the dhcp server
-(
- [ -z "$dhcp_enable" -o "$dhcp_enable" -eq 1 ] && {
- # no existing DHCP server?
-
- # calculate settings
- eval "ipaddr=\${${iface}_ipaddr}"
- eval "netmask=\${${iface}_netmask}"
- eval $(ipcalc $ipaddr $netmask ${dhcp_start:-100} ${dhcp_num:-150})
-
- # and pass the args via config parser defines
- echo "@define dhcp_enable 1"
- echo "@define netmask $NETMASK"
- echo "@define start $START"
- echo "@define end $END"
- echo "@define lease ${dhcp_lease:-12h}"
- }
-
- # ignore requests from wan interface
- [ -z "$wan_proto" -o "$wan_proto" = "none" ] || echo "@define wan_ifname $wan_ifname"
-
- cat /etc/dnsmasq.conf
-) | awk -f /usr/lib/parse-config.awk | dnsmasq -C /proc/self/fd/0
diff --git a/openwrt/package/dnsmasq/ipkg/dnsmasq.conffiles b/openwrt/package/dnsmasq/ipkg/dnsmasq.conffiles
deleted file mode 100644
index e30eba8f66..0000000000
--- a/openwrt/package/dnsmasq/ipkg/dnsmasq.conffiles
+++ /dev/null
@@ -1 +0,0 @@
-/etc/dnsmasq.conf
diff --git a/openwrt/package/dnsmasq/ipkg/dnsmasq.control b/openwrt/package/dnsmasq/ipkg/dnsmasq.control
deleted file mode 100644
index 6f61edc656..0000000000
--- a/openwrt/package/dnsmasq/ipkg/dnsmasq.control
+++ /dev/null
@@ -1,4 +0,0 @@
-Package: dnsmasq
-Priority: essential
-Section: net
-Description: A lightweight DNS and DHCP server
diff --git a/openwrt/package/dnsmasq/patches/101-ipv6.patch b/openwrt/package/dnsmasq/patches/101-ipv6.patch
deleted file mode 100644
index 5cbf781744..0000000000
--- a/openwrt/package/dnsmasq/patches/101-ipv6.patch
+++ /dev/null
@@ -1,13 +0,0 @@
---- dnsmasq-2.15.orig/src/config.h 2004-09-20 15:47:57.000000000 +0200
-+++ dnsmasq-2.15/src/config.h 2004-09-20 23:21:10.000000000 +0200
-@@ -78,8 +78,9 @@
- /* We assume that systems which don't have IPv6
- headers don't have ntop and pton either */
-
--#if defined(INET6_ADDRSTRLEN) && defined(IPV6_V6ONLY) && !defined(NO_IPV6)
-+#if defined(INET6_ADDRSTRLEN) && !defined(NO_IPV6)
- # define HAVE_IPV6
-+# define IPV6_V6ONLY 26
- # define ADDRSTRLEN INET6_ADDRSTRLEN
- # if defined(SOL_IPV6)
- # define IPV6_LEVEL SOL_IPV6