aboutsummaryrefslogtreecommitdiffstats
path: root/openwrt/package/bridge
diff options
context:
space:
mode:
Diffstat (limited to 'openwrt/package/bridge')
-rw-r--r--openwrt/package/bridge/Config.in10
-rw-r--r--openwrt/package/bridge/Makefile49
-rw-r--r--openwrt/package/bridge/ipkg/bridge.control4
-rw-r--r--openwrt/package/bridge/patches/patch-libbridge_Makefile_in11
4 files changed, 0 insertions, 74 deletions
diff --git a/openwrt/package/bridge/Config.in b/openwrt/package/bridge/Config.in
deleted file mode 100644
index b7f7babc68..0000000000
--- a/openwrt/package/bridge/Config.in
+++ /dev/null
@@ -1,10 +0,0 @@
-config BR2_PACKAGE_BRIDGE
- prompt "bridge............................ Ethernet bridging configuration utility"
- tristate
- default y
- help
- Manage ethernet bridging; a way to connect networks together to
- form a larger network.
-
- http://bridge.sourceforge.net/
-
diff --git a/openwrt/package/bridge/Makefile b/openwrt/package/bridge/Makefile
deleted file mode 100644
index 601373b994..0000000000
--- a/openwrt/package/bridge/Makefile
+++ /dev/null
@@ -1,49 +0,0 @@
-# $Id$
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=bridge
-PKG_VERSION:=1.0.6
-PKG_RELEASE:=1
-PKG_MD5SUM:=9b7dc52656f5cbec846a7ba3299f73bd
-
-PKG_SOURCE_URL:=@SF/bridge
-PKG_SOURCE:=bridge-utils-$(PKG_VERSION).tar.gz
-PKG_BUILD_DIR:=$(BUILD_DIR)/bridge-utils-$(PKG_VERSION)
-PKG_CAT:=zcat
-
-include $(TOPDIR)/package/rules.mk
-$(eval $(call PKG_template,BRIDGE,bridge,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-
-$(PKG_BUILD_DIR)/.configured:
- (cd $(PKG_BUILD_DIR); rm -rf config.cache; \
- $(TARGET_CONFIGURE_OPTS) \
- CFLAGS="$(TARGET_CFLAGS)" \
- ./configure \
- --target=$(GNU_TARGET_NAME) \
- --host=$(GNU_TARGET_NAME) \
- --build=$(GNU_HOST_NAME) \
- --prefix=/usr \
- --exec-prefix=/usr \
- --bindir=/usr/bin \
- --sbindir=/usr/sbin \
- --libexecdir=/usr/lib \
- --sysconfdir=/etc \
- --datadir=/usr/share \
- --localstatedir=/var \
- --mandir=/usr/man \
- --infodir=/usr/info \
- $(DISABLE_NLS) \
- --with-linux-headers=$(LINUX_DIR) \
- );
- touch $@
-
-$(PKG_BUILD_DIR)/.built:
- $(MAKE) -C $(PKG_BUILD_DIR)
- touch $@
-
-$(IPKG_BRIDGE):
- mkdir -p $(IDIR_BRIDGE)/usr/sbin
- $(CP) $(PKG_BUILD_DIR)/brctl/brctl $(IDIR_BRIDGE)/usr/sbin/
- $(STRIP) $(IDIR_BRIDGE)/usr/sbin/brctl
- $(IPKG_BUILD) $(IDIR_BRIDGE) $(PACKAGE_DIR)
diff --git a/openwrt/package/bridge/ipkg/bridge.control b/openwrt/package/bridge/ipkg/bridge.control
deleted file mode 100644
index cc7c9d9c83..0000000000
--- a/openwrt/package/bridge/ipkg/bridge.control
+++ /dev/null
@@ -1,4 +0,0 @@
-Package: bridge
-Priority: essential
-Section: net
-Description: Ethernet bridging tools
diff --git a/openwrt/package/bridge/patches/patch-libbridge_Makefile_in b/openwrt/package/bridge/patches/patch-libbridge_Makefile_in
deleted file mode 100644
index f44737750b..0000000000
--- a/openwrt/package/bridge/patches/patch-libbridge_Makefile_in
+++ /dev/null
@@ -1,11 +0,0 @@
---- bridge-utils-0.9.6/libbridge/Makefile.in.dist 2004-03-01 20:55:52.000000000 -0600
-+++ bridge-utils-0.9.6/libbridge/Makefile.in 2004-03-01 20:56:23.000000000 -0600
-@@ -5,7 +5,7 @@
- RANLIB=@RANLIB@
-
- CC=@CC@
--CFLAGS = -Wall -g $(KERNEL_HEADERS)
-+CFLAGS = -Wall -g @CFLAGS@ $(KERNEL_HEADERS)
-
- prefix=@prefix@
- exec_prefix=@exec_prefix@