aboutsummaryrefslogtreecommitdiffstats
path: root/openwrt/package/bluez-utils
diff options
context:
space:
mode:
Diffstat (limited to 'openwrt/package/bluez-utils')
-rw-r--r--openwrt/package/bluez-utils/Config.in13
-rw-r--r--openwrt/package/bluez-utils/Makefile91
-rw-r--r--openwrt/package/bluez-utils/files/givepin14
-rw-r--r--openwrt/package/bluez-utils/ipkg/bluez-utils.conffiles3
-rw-r--r--openwrt/package/bluez-utils/ipkg/bluez-utils.control5
-rw-r--r--openwrt/package/bluez-utils/patches/001-include_limits.patch22
-rw-r--r--openwrt/package/bluez-utils/patches/002-hcid_pin_helper.patch21
7 files changed, 0 insertions, 169 deletions
diff --git a/openwrt/package/bluez-utils/Config.in b/openwrt/package/bluez-utils/Config.in
deleted file mode 100644
index 7875742e7c..0000000000
--- a/openwrt/package/bluez-utils/Config.in
+++ /dev/null
@@ -1,13 +0,0 @@
-config BR2_PACKAGE_BLUEZ_UTILS
- prompt "bluez-utils....................... Bluetooth utilities"
- tristate
- default m if CONFIG_DEVEL
- select BR2_PACKAGE_GLIB1
- select BR2_PACKAGE_BLUEZ_LIBS
- help
- Bluez utils.
-
- http://bluez.org
-
- Depends: libpthread, bluez-libs
-
diff --git a/openwrt/package/bluez-utils/Makefile b/openwrt/package/bluez-utils/Makefile
deleted file mode 100644
index 1ac7d345d6..0000000000
--- a/openwrt/package/bluez-utils/Makefile
+++ /dev/null
@@ -1,91 +0,0 @@
-# $Id$
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=bluez-utils
-PKG_VERSION:=2.24
-PKG_RELEASE:=1
-PKG_MD5SUM:=
-
-PKG_SOURCE_URL:=http://bluez.sourceforge.net/download
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
-
-include $(TOPDIR)/package/rules.mk
-
-$(eval $(call PKG_template,BLUEZ_UTILS,bluez-utils,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-
-$(PKG_BUILD_DIR)/.source: $(DL_DIR)/$(PKG_SOURCE)
- zcat $(DL_DIR)/$(PKG_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
- touch $(BLUEZLIBS_DIR)/.source
-
-$(PKG_BUILD_DIR)/.configured:
- (cd $(PKG_BUILD_DIR); rm -rf config.{cache,status} ; \
- $(TARGET_CONFIGURE_OPTS) \
- CFLAGS="$(TARGET_CFLAGS)" \
- CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
- LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
- ./configure \
- --target=$(GNU_TARGET_NAME) \
- --host=$(GNU_TARGET_NAME) \
- --build=$(GNU_HOST_NAME) \
- --program-prefix="" \
- --program-suffix="" \
- --prefix=/usr \
- --exec-prefix=/usr \
- --bindir=/usr/bin \
- --datadir=/usr/share \
- --includedir=/usr/include \
- --infodir=/usr/share/info \
- --libdir=/usr/lib \
- --libexecdir=/usr/lib \
- --localstatedir=/var \
- --mandir=/usr/share/man \
- --sbindir=/usr/sbin \
- --sysconfdir=/etc \
- $(DISABLE_LARGEFILE) \
- $(DISABLE_NLS) \
- --enable-shared \
- --enable-static \
- --disable-rpath \
- --disable-dbus \
- --disable-fuse \
- --disable-obex \
- --disable-alsa \
- --disable-cups \
- --disable-pcmcia \
- --disable-initscripts \
- --disable-bccmd \
- --disable-avctrl \
- --disable-hid2hci \
- --disable-dfutool \
- --disable-bcm203x \
- --disable-bluepin \
- --with-bluez=$(STAGING_DIR)/usr/include \
- --with-usb=$(STAGING_DIR)/usr/include \
- )
- touch $@
-
-$(PKG_BUILD_DIR)/.built:
- rm -rf $(PKG_INSTALL_DIR)
- mkdir -p $(PKG_INSTALL_DIR)
- $(MAKE) -C $(PKG_BUILD_DIR) \
- DESTDIR="$(PKG_INSTALL_DIR)" \
- all install
- touch $@
-
-$(IPKG_BLUEZ_UTILS):
- install -d -m0755 $(IDIR_BLUEZ_UTILS)/usr/bin
- $(CP) $(PKG_INSTALL_DIR)/usr/bin/* $(IDIR_BLUEZ_UTILS)/usr/bin/
- install -d -m0755 $(IDIR_BLUEZ_UTILS)/usr/sbin
- $(CP) $(PKG_INSTALL_DIR)/usr/sbin/* $(IDIR_BLUEZ_UTILS)/usr/sbin/
- install -d -m0755 $(IDIR_BLUEZ_UTILS)/etc/bluetooth
- $(CP) $(PKG_INSTALL_DIR)/../hcid/hcid.conf $(IDIR_BLUEZ_UTILS)/etc/bluetooth/
- $(CP) $(PKG_INSTALL_DIR)/../rfcomm/rfcomm.conf $(IDIR_BLUEZ_UTILS)/etc/bluetooth/
- install -m0700 ./files/givepin $(IDIR_BLUEZ_UTILS)/etc/bluetooth/
- $(RSTRIP) $(IDIR_BLUEZ_UTILS)
- $(IPKG_BUILD) $(IDIR_BLUEZ_UTILS) $(PACKAGE_DIR)
-
diff --git a/openwrt/package/bluez-utils/files/givepin b/openwrt/package/bluez-utils/files/givepin
deleted file mode 100644
index e52a3384af..0000000000
--- a/openwrt/package/bluez-utils/files/givepin
+++ /dev/null
@@ -1,14 +0,0 @@
-#!/bin/sh
-
-# Write bluetooth PIN number here:
-pin=
-
-if [ -z "$pin" ]; then
- msg="Set bluetooth PIN in file $0"
- logger -p user.err "$msg"
- for i in /dev/pts/* ; do
- [ -w $i ] && echo "$msg" > $i
- done
-else
- echo "PIN:$pin"
-fi
diff --git a/openwrt/package/bluez-utils/ipkg/bluez-utils.conffiles b/openwrt/package/bluez-utils/ipkg/bluez-utils.conffiles
deleted file mode 100644
index ba07831a92..0000000000
--- a/openwrt/package/bluez-utils/ipkg/bluez-utils.conffiles
+++ /dev/null
@@ -1,3 +0,0 @@
-/etc/bluetooth/givepin
-/etc/bluetooth/hcid.conf
-/etc/bluetooth/rfcomm.conf
diff --git a/openwrt/package/bluez-utils/ipkg/bluez-utils.control b/openwrt/package/bluez-utils/ipkg/bluez-utils.control
deleted file mode 100644
index f577660b19..0000000000
--- a/openwrt/package/bluez-utils/ipkg/bluez-utils.control
+++ /dev/null
@@ -1,5 +0,0 @@
-Package: bluez-utils
-Priority: optional
-Section: net
-Description: Bluez utils
-Depends: kmod-bluetooth, bluez-libs
diff --git a/openwrt/package/bluez-utils/patches/001-include_limits.patch b/openwrt/package/bluez-utils/patches/001-include_limits.patch
deleted file mode 100644
index 6f6cb824b4..0000000000
--- a/openwrt/package/bluez-utils/patches/001-include_limits.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-diff -ur bluez-utils-2.17.orig/hidd/sdp.c bluez-utils-2.17/hidd/sdp.c
---- bluez-utils-2.17.orig/hidd/sdp.c 2005-05-09 20:33:24.000000000 +0200
-+++ bluez-utils-2.17/hidd/sdp.c 2005-07-26 14:38:13.000000000 +0200
-@@ -39,6 +39,7 @@
- #include <string.h>
- #include <sys/stat.h>
- #include <sys/socket.h>
-+#include <linux/limits.h>
-
- #include <bluetooth/bluetooth.h>
- #include <bluetooth/l2cap.h>
-diff -ur bluez-utils-2.17.orig/tools/hciconfig.c bluez-utils-2.17/tools/hciconfig.c
---- bluez-utils-2.17.orig/tools/hciconfig.c 2005-05-09 20:33:24.000000000 +0200
-+++ bluez-utils-2.17/tools/hciconfig.c 2005-07-26 14:34:29.000000000 +0200
-@@ -40,6 +40,7 @@
- #include <getopt.h>
- #include <sys/ioctl.h>
- #include <sys/socket.h>
-+#include <linux/limits.h>
-
- #include <bluetooth/bluetooth.h>
- #include <bluetooth/hci.h>
diff --git a/openwrt/package/bluez-utils/patches/002-hcid_pin_helper.patch b/openwrt/package/bluez-utils/patches/002-hcid_pin_helper.patch
deleted file mode 100644
index 17a7f36403..0000000000
--- a/openwrt/package/bluez-utils/patches/002-hcid_pin_helper.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-diff -ur bluez-utils-2.17.orig/hcid/hcid.conf bluez-utils-2.17/hcid/hcid.conf
---- bluez-utils-2.17.orig/hcid/hcid.conf 2004-12-25 19:06:00.000000000 +0100
-+++ bluez-utils-2.17/hcid/hcid.conf 2005-07-26 14:44:23.000000000 +0200
-@@ -23,7 +23,7 @@
- pairing multi;
-
- # PIN helper
-- pin_helper /usr/bin/bluepin;
-+ pin_helper /etc/bluetooth/givepin;
-
- # D-Bus PIN helper
- #dbus_pin_helper;
-@@ -34,7 +34,7 @@
- # Local device name
- # %d - device id
- # %h - host name
-- name "BlueZ (%d)";
-+ name "OpenWRT";
-
- # Local device class
- class 0x3e0100;