aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
Diffstat (limited to 'include')
-rw-r--r--include/scan.mk1
-rw-r--r--include/target.mk1
2 files changed, 2 insertions, 0 deletions
diff --git a/include/scan.mk b/include/scan.mk
index 0998333439..2f2753f2a0 100644
--- a/include/scan.mk
+++ b/include/scan.mk
@@ -78,3 +78,4 @@ $(TMP_DIR)/.$(SCAN_TARGET): $(TARGET_STAMP) $(SCAN_STAMP)
FORCE:
.PHONY: FORCE
.NOTPARALLEL:
+.ONESHELL:
diff --git a/include/target.mk b/include/target.mk
index 3401f849a5..657109e75d 100644
--- a/include/target.mk
+++ b/include/target.mk
@@ -19,6 +19,7 @@ DEFAULT_PACKAGES.bootloader:=
ifneq ($(DUMP),)
all: dumpinfo
+ .ONESHELL:
endif
target_conf=$(subst .,_,$(subst -,_,$(subst /,_,$(1))))