aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
Diffstat (limited to 'include')
-rw-r--r--include/package-ipkg.mk16
1 files changed, 8 insertions, 8 deletions
diff --git a/include/package-ipkg.mk b/include/package-ipkg.mk
index 2591f5e7e9..c90eeb2b46 100644
--- a/include/package-ipkg.mk
+++ b/include/package-ipkg.mk
@@ -103,20 +103,20 @@ ifeq ($(DUMP),)
ifneq ($(ABI_VERSION),)
compile: $(PKG_INFO_DIR)/$(1).version
endif
+ else
+ $(if $(CONFIG_PACKAGE_$(1)),$$(info WARNING: skipping $(1) -- package not selected))
+ endif
- ifeq ($(CONFIG_PACKAGE_$(1)),y)
- .PHONY: $(PKG_INSTALL_STAMP).$(1)
- compile: $(PKG_INSTALL_STAMP).$(1)
- $(PKG_INSTALL_STAMP).$(1):
+ .PHONY: $(PKG_INSTALL_STAMP).$(1)
+ compile: $(PKG_INSTALL_STAMP).$(1)
+ $(PKG_INSTALL_STAMP).$(1):
if [ -f $(PKG_INSTALL_STAMP).clean ]; then \
rm -f \
$(PKG_INSTALL_STAMP) \
$(PKG_INSTALL_STAMP).clean; \
- fi; \
+ fi
+ ifeq ($(CONFIG_PACKAGE_$(1)),y)
echo "$(1)" >> $(PKG_INSTALL_STAMP)
- endif
- else
- $(if $(CONFIG_PACKAGE_$(1)),$$(info WARNING: skipping $(1) -- package not selected))
endif
endif
endif