aboutsummaryrefslogtreecommitdiffstats
path: root/include/toplevel.mk
diff options
context:
space:
mode:
Diffstat (limited to 'include/toplevel.mk')
-rw-r--r--include/toplevel.mk11
1 files changed, 11 insertions, 0 deletions
diff --git a/include/toplevel.mk b/include/toplevel.mk
index 23d70ac81a..10b81049c5 100644
--- a/include/toplevel.mk
+++ b/include/toplevel.mk
@@ -156,6 +156,15 @@ prereq:: prepare-tmpinfo .config
@+$(MAKE) -r -s tmp/.prereq-build $(PREP_MK)
@+$(NO_TRACE_MAKE) -r -s $@
+ifeq ($(SDK),1)
+
+%::
+ @+$(PREP_MK) $(NO_TRACE_MAKE) -r -s prereq
+ @./scripts/config/conf --defconfig=.config Config.in
+ @+$(ULIMIT_FIX) $(SUBMAKE) -r $@
+
+else
+
%::
@+$(PREP_MK) $(NO_TRACE_MAKE) -r -s prereq
@( \
@@ -167,6 +176,8 @@ prereq:: prepare-tmpinfo .config
)
@+$(ULIMIT_FIX) $(SUBMAKE) -r $@
+endif
+
help:
cat README