aboutsummaryrefslogtreecommitdiffstats
path: root/include/toplevel.mk
diff options
context:
space:
mode:
Diffstat (limited to 'include/toplevel.mk')
-rw-r--r--include/toplevel.mk10
1 files changed, 1 insertions, 9 deletions
diff --git a/include/toplevel.mk b/include/toplevel.mk
index 4003b48241..d3500ef58f 100644
--- a/include/toplevel.mk
+++ b/include/toplevel.mk
@@ -19,7 +19,6 @@ else
SOURCE_DATE_EPOCH:=$(shell $(TOPDIR)/scripts/get_source_date_epoch.sh)
endif
-HOSTCC ?= $(CC)
export REVISION
export SOURCE_DATE_EPOCH
export GIT_CONFIG_PARAMETERS='core.autocrlf=false'
@@ -59,13 +58,6 @@ export PATH:=$(path)
unexport TAR_OPTIONS
-ifneq ($(shell $(HOSTCC) 2>&1 | grep clang),)
- export HOSTCC_REAL?=$(HOSTCC)
- export HOSTCC_WRAPPER:=$(TOPDIR)/scripts/clang-gcc-wrapper
-else
- export HOSTCC_WRAPPER:=$(HOSTCC)
-endif
-
ifeq ($(FORCE),)
.config scripts/config/conf scripts/config/mconf: staging_dir/host/.prereq-build
endif
@@ -115,7 +107,7 @@ endif
scripts/config/%onf: CFLAGS+= -O2
scripts/config/%onf:
@$(_SINGLE)$(SUBMAKE) $(if $(findstring s,$(OPENWRT_VERBOSE)),,-s) \
- -C scripts/config $(notdir $@) CC="$(HOSTCC_WRAPPER)"
+ -C scripts/config $(notdir $@)
$(eval $(call rdep,scripts/config,scripts/config/mconf))