aboutsummaryrefslogtreecommitdiffstats
path: root/include/scons.mk
diff options
context:
space:
mode:
Diffstat (limited to 'include/scons.mk')
-rw-r--r--include/scons.mk23
1 files changed, 0 insertions, 23 deletions
diff --git a/include/scons.mk b/include/scons.mk
deleted file mode 100644
index 2b76710542..0000000000
--- a/include/scons.mk
+++ /dev/null
@@ -1,23 +0,0 @@
-export PLATFORM=posix
-
-SCONS_VARS = \
- CC="$(TARGET_CC_NOCACHE)" \
- CXX="$(TARGET_CXX_NOCACHE)" \
- CFLAGS="$(TARGET_CFLAGS) $(EXTRA_CFLAGS)" \
- CXXFLAGS="$(TARGET_CXXFLAGS) $(EXTRA_CXXFLAGS)" \
- CPPFLAGS="$(TARGET_CPPFLAGS) $(EXTRA_CPPFLAGS)" \
- LDFLAGS="$(TARGET_LDFLAGS) $(EXTRA_LDFLAGS)" \
- DESTDIR="$(PKG_INSTALL_DIR)"
-
-define Build/Configure/Default
- (cd $(PKG_BUILD_DIR); \
- $(SCONS_VARS) \
- scons \
- prefix=/usr \
- $(SCONS_OPTIONS) \
- install \
- )
-endef
-
-define Build/Compile
-endef