aboutsummaryrefslogtreecommitdiffstats
path: root/include/package-dumpinfo.mk
diff options
context:
space:
mode:
Diffstat (limited to 'include/package-dumpinfo.mk')
-rw-r--r--include/package-dumpinfo.mk25
1 files changed, 0 insertions, 25 deletions
diff --git a/include/package-dumpinfo.mk b/include/package-dumpinfo.mk
index 7cc8f3f6dc..68a66d0769 100644
--- a/include/package-dumpinfo.mk
+++ b/include/package-dumpinfo.mk
@@ -49,29 +49,4 @@ $(Package/$(1)/config)
))
endef
-define Feature/Default
- TARGET_NAME:=
- TARGET_TITLE:=
- PRIORITY:=
- NAME:=
-endef
-
-define Feature
- $(eval $(Feature/Default))
- $(eval $(Feature/$(1)))
- $(if $(DUMP),$(call Dumpinfo/Feature,$(1)))
-endef
-
-define Dumpinfo/Feature
-$(info Feature: $(TARGET_NAME)_$(1)
-Target-Name: $(TARGET_NAME)
-Target-Title: $(TARGET_TITLE)
-Feature-Name: $(NAME)
-$(if $(PRIORITY),Feature-Priority: $(PRIORITY)
-)Feature-Description:
-$(Feature/$(1)/description)
-@@
-)
-endef
-
endif