aboutsummaryrefslogtreecommitdiffstats
path: root/include/host-build.mk
diff options
context:
space:
mode:
Diffstat (limited to 'include/host-build.mk')
-rw-r--r--include/host-build.mk17
1 files changed, 4 insertions, 13 deletions
diff --git a/include/host-build.mk b/include/host-build.mk
index 6c2f91581b..0bd386781d 100644
--- a/include/host-build.mk
+++ b/include/host-build.mk
@@ -168,13 +168,11 @@ ifndef DUMP
touch $(HOST_STAMP_BUILT)
touch $$@
+ $(call DefaultTargets,$(patsubst %,host-%,$(DEFAULT_SUBDIR_TARGETS)))
ifndef STAMP_BUILT
- prepare: host-prepare
- compile: host-compile
- install: host-install
- clean: host-clean
- update: host-update
- refresh: host-refresh
+ $(foreach t,$(DEFAULT_SUBDIR_TARGETS),
+ $(t): host-$(t)
+ )
endif
host-prepare: $(HOST_STAMP_PREPARED)
@@ -187,13 +185,6 @@ ifndef DUMP
rm -rf $(HOST_BUILD_DIR) $(HOST_STAMP_INSTALLED) $(HOST_STAMP_BUILT)
endef
-
- download:
- prepare:
- compile:
- install:
- clean:
-
endif
define HostBuild