aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index fd705a37ad..32c050bb48 100644
--- a/Makefile
+++ b/Makefile
@@ -88,6 +88,14 @@ prereq: $(target/stamp-prereq) tmp/.prereq_packages
exit 1; \
fi
+$(BIN_DIR)/profiles.json: FORCE
+ $(if $(CONFIG_JSON_OVERVIEW_IMAGE_INFO), \
+ WORK_DIR=$(BUILD_DIR)/json_info_files \
+ $(SCRIPT_DIR)/json_overview_image_info.py $@ \
+ )
+
+json_overview_image_info: $(BIN_DIR)/profiles.json
+
checksum: FORCE
$(call sha256sums,$(BIN_DIR),$(CONFIG_BUILDBOT))
@@ -109,6 +117,7 @@ prepare: .config $(tools/stamp-compile) $(toolchain/stamp-compile)
world: prepare $(target/stamp-compile) $(package/stamp-compile) $(package/stamp-install) $(target/stamp-install) FORCE
$(_SINGLE)$(SUBMAKE) -r package/index
+ $(_SINGLE)$(SUBMAKE) -r json_overview_image_info
$(_SINGLE)$(SUBMAKE) -r checksum
.PHONY: clean dirclean prereq prepare world package/symlinks package/symlinks-install package/symlinks-clean