aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorPaul Spooren <mail@aparcar.org>2020-03-12 12:55:41 -1000
committerPetr Štetiar <ynezz@true.cz>2020-04-03 12:17:45 +0200
commit07449f692ce4c4525e946401f4c3ed0cbbc8c4df (patch)
tree5ae34a428c8a0221d82d75461f38275de97d77dd /Makefile
parentfcd14017007db35a4a41ef4fd6b69a5e02edbd5e (diff)
downloadupstream-07449f692ce4c4525e946401f4c3ed0cbbc8c4df.tar.gz
upstream-07449f692ce4c4525e946401f4c3ed0cbbc8c4df.tar.bz2
upstream-07449f692ce4c4525e946401f4c3ed0cbbc8c4df.zip
build: refactor JSON info files to `profiles.json`
JSON info files contain machine readable information of built profiles and resulting images. These files were added in commit 881ed09ee6e2 ("build: create JSON files containing image info"). They are useful for firmware wizards and script checking for reproducibility. Currently all JSON files are stored next to the built images, resulting in up to 168 individual files for the ath79/generic target. This patch refactors the JSON creation to store individual per image (not per profile) files in $(BUILD_DIR)/json_info_files and create an single overview file called `profiles.json` in the target directory. Storing per image files and not per profile solves the problem of parallel file writes. If a profiles sysupgrade and factory image are finished at the same time both processes would write to the same JSON file, resulting in randomly broken outputs. Some target like x86/64 do not use the image code yet, resulting in missing JSON files. If no JSON info files were created, no `profiles.json` files is created as it would be empty anyway. As before, this creation is enabled by default only if `BUILDBOT` is set. Tested via buildroot & ImageBuilder on ath79/generic, imx6 and x86/64. Signed-off-by: Paul Spooren <mail@aparcar.org> [json_info_files dir handling in Make, if case refactoring] Signed-off-by: Petr Štetiar <ynezz@true.cz>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index fd705a37ad..32c050bb48 100644
--- a/Makefile
+++ b/Makefile
@@ -88,6 +88,14 @@ prereq: $(target/stamp-prereq) tmp/.prereq_packages
exit 1; \
fi
+$(BIN_DIR)/profiles.json: FORCE
+ $(if $(CONFIG_JSON_OVERVIEW_IMAGE_INFO), \
+ WORK_DIR=$(BUILD_DIR)/json_info_files \
+ $(SCRIPT_DIR)/json_overview_image_info.py $@ \
+ )
+
+json_overview_image_info: $(BIN_DIR)/profiles.json
+
checksum: FORCE
$(call sha256sums,$(BIN_DIR),$(CONFIG_BUILDBOT))
@@ -109,6 +117,7 @@ prepare: .config $(tools/stamp-compile) $(toolchain/stamp-compile)
world: prepare $(target/stamp-compile) $(package/stamp-compile) $(package/stamp-install) $(target/stamp-install) FORCE
$(_SINGLE)$(SUBMAKE) -r package/index
+ $(_SINGLE)$(SUBMAKE) -r json_overview_image_info
$(_SINGLE)$(SUBMAKE) -r checksum
.PHONY: clean dirclean prereq prepare world package/symlinks package/symlinks-install package/symlinks-clean