aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/base-files/Makefile2
-rwxr-xr-xpackage/base-files/files/etc/init.d/boot5
-rw-r--r--package/network/services/ipset-dns/files/ipset-dns.config2
3 files changed, 5 insertions, 4 deletions
diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index f203c29e95..35ad80888f 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -12,7 +12,7 @@ include $(INCLUDE_DIR)/version.mk
include $(INCLUDE_DIR)/feeds.mk
PKG_NAME:=base-files
-PKG_RELEASE:=211
+PKG_RELEASE:=212
PKG_FLAGS:=nonshared
PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
diff --git a/package/base-files/files/etc/init.d/boot b/package/base-files/files/etc/init.d/boot
index 09b7f44c79..44311c9e23 100755
--- a/package/base-files/files/etc/init.d/boot
+++ b/package/base-files/files/etc/init.d/boot
@@ -31,8 +31,9 @@ boot() {
chmod 0700 /tmp/.uci
touch /var/log/wtmp
touch /var/log/lastlog
- touch /tmp/resolv.conf.auto
- ln -sf /tmp/resolv.conf.auto /tmp/resolv.conf
+ mkdir -p /tmp/resolv.conf.d
+ touch /tmp/resolv.conf.d/resolv.conf.auto
+ ln -sf /tmp/resolv.conf.d/resolv.conf.auto /tmp/resolv.conf
grep -q debugfs /proc/filesystems && /bin/mount -o noatime -t debugfs debugfs /sys/kernel/debug
[ "$FAILSAFE" = "true" ] && touch /tmp/.failsafe
diff --git a/package/network/services/ipset-dns/files/ipset-dns.config b/package/network/services/ipset-dns/files/ipset-dns.config
index 0270366af7..538d3a01a3 100644
--- a/package/network/services/ipset-dns/files/ipset-dns.config
+++ b/package/network/services/ipset-dns/files/ipset-dns.config
@@ -11,6 +11,6 @@ config ipset-dns
#option port '53001'
# use given upstream DNS server,
- # defaults to first entry in /tmp/resolv.conf.auto
+ # defaults to first entry in /tmp/resolv.conf.d/resolv.conf.auto
#option dns '8.8.8.8'