aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--openwrt/target/linux/ar531x-2.4/config2
-rw-r--r--openwrt/target/linux/aruba-2.6/config2
-rw-r--r--openwrt/target/linux/brcm-2.4/config2
-rw-r--r--openwrt/target/linux/brcm-2.6/config2
-rw-r--r--openwrt/target/linux/control/kmod-fs-minix.control4
-rw-r--r--openwrt/target/linux/generic-2.4/modules.mk4
-rw-r--r--openwrt/target/linux/generic-2.6/modules.mk4
-rw-r--r--openwrt/target/linux/x86-2.4/config2
-rw-r--r--openwrt/target/linux/x86-2.6/config2
9 files changed, 18 insertions, 6 deletions
diff --git a/openwrt/target/linux/ar531x-2.4/config b/openwrt/target/linux/ar531x-2.4/config
index 77c5beb3c2..e48d8d0eea 100644
--- a/openwrt/target/linux/ar531x-2.4/config
+++ b/openwrt/target/linux/ar531x-2.4/config
@@ -836,7 +836,7 @@ CONFIG_JOLIET=y
# CONFIG_JFS_FS is not set
# CONFIG_JFS_DEBUG is not set
# CONFIG_JFS_STATISTICS is not set
-# CONFIG_MINIX_FS is not set
+CONFIG_MINIX_FS=m
# CONFIG_VXFS_FS is not set
# CONFIG_NTFS_FS is not set
# CONFIG_NTFS_RW is not set
diff --git a/openwrt/target/linux/aruba-2.6/config b/openwrt/target/linux/aruba-2.6/config
index e662d99fee..a5e81fe13b 100644
--- a/openwrt/target/linux/aruba-2.6/config
+++ b/openwrt/target/linux/aruba-2.6/config
@@ -1272,7 +1272,7 @@ CONFIG_JFS_FS=m
# CONFIG_JFS_STATISTICS is not set
# CONFIG_FS_POSIX_ACL is not set
# CONFIG_XFS_FS is not set
-# CONFIG_MINIX_FS is not set
+CONFIG_MINIX_FS=m
# CONFIG_ROMFS_FS is not set
# CONFIG_INOTIFY is not set
# CONFIG_QUOTA is not set
diff --git a/openwrt/target/linux/brcm-2.4/config b/openwrt/target/linux/brcm-2.4/config
index 26d9cd102a..d40fc72fea 100644
--- a/openwrt/target/linux/brcm-2.4/config
+++ b/openwrt/target/linux/brcm-2.4/config
@@ -1038,7 +1038,7 @@ CONFIG_JOLIET=y
# CONFIG_JFS_FS is not set
# CONFIG_JFS_DEBUG is not set
# CONFIG_JFS_STATISTICS is not set
-# CONFIG_MINIX_FS is not set
+CONFIG_MINIX_FS=m
# CONFIG_VXFS_FS is not set
# CONFIG_NTFS_FS is not set
# CONFIG_NTFS_RW is not set
diff --git a/openwrt/target/linux/brcm-2.6/config b/openwrt/target/linux/brcm-2.6/config
index b3a9c5dee1..9a674063c2 100644
--- a/openwrt/target/linux/brcm-2.6/config
+++ b/openwrt/target/linux/brcm-2.6/config
@@ -1448,7 +1448,7 @@ CONFIG_XFS_FS=m
# CONFIG_XFS_SECURITY is not set
# CONFIG_XFS_POSIX_ACL is not set
# CONFIG_XFS_RT is not set
-# CONFIG_MINIX_FS is not set
+CONFIG_MINIX_FS=m
# CONFIG_ROMFS_FS is not set
CONFIG_INOTIFY=y
# CONFIG_QUOTA is not set
diff --git a/openwrt/target/linux/control/kmod-fs-minix.control b/openwrt/target/linux/control/kmod-fs-minix.control
new file mode 100644
index 0000000000..2169ba6acd
--- /dev/null
+++ b/openwrt/target/linux/control/kmod-fs-minix.control
@@ -0,0 +1,4 @@
+Package: kmod-fs-minix
+Priority: optional
+Section: sys
+Description: Kernel modules for MINIX filesystem support
diff --git a/openwrt/target/linux/generic-2.4/modules.mk b/openwrt/target/linux/generic-2.4/modules.mk
index 9efcce760a..e65ef8186d 100644
--- a/openwrt/target/linux/generic-2.4/modules.mk
+++ b/openwrt/target/linux/generic-2.4/modules.mk
@@ -142,6 +142,10 @@ $(eval $(call KMOD_template,FS_CIFS,fs-cifs,\
$(MODULES_DIR)/kernel/fs/cifs/cifs.o \
,CONFIG_CIFS,,30,cifs))
+$(eval $(call KMOD_template,FS_MINIX,fs-minix,\
+ $(MODULES_DIR)/kernel/fs/minix/*.o \
+,CONFIG_MINIX_FS,,30,minix))
+
$(eval $(call KMOD_template,FS_EXT2,fs-ext2,\
$(MODULES_DIR)/kernel/fs/ext2/*.o \
,CONFIG_EXT2_FS,,30,ext2))
diff --git a/openwrt/target/linux/generic-2.6/modules.mk b/openwrt/target/linux/generic-2.6/modules.mk
index 71b3df577d..7765c1297d 100644
--- a/openwrt/target/linux/generic-2.6/modules.mk
+++ b/openwrt/target/linux/generic-2.6/modules.mk
@@ -133,6 +133,10 @@ $(eval $(call KMOD_template,FS_CIFS,fs-cifs,\
$(MODULES_DIR)/kernel/fs/cifs/cifs.ko \
,CONFIG_CIFS,kmod-nls-base,30,cifs))
+$(eval $(call KMOD_template,FS_MINIX,fs-minix,\
+ $(MODULES_DIR)/kernel/fs/minix/minix.ko \
+,CONFIG_MINIX_FS,,30,minix))
+
$(eval $(call KMOD_template,FS_EXT2,fs-ext2,\
$(MODULES_DIR)/kernel/fs/ext2/ext2.ko \
,CONFIG_EXT2_FS,,30,ext2))
diff --git a/openwrt/target/linux/x86-2.4/config b/openwrt/target/linux/x86-2.4/config
index 339196f29a..d46dc3cfdf 100644
--- a/openwrt/target/linux/x86-2.4/config
+++ b/openwrt/target/linux/x86-2.4/config
@@ -1027,7 +1027,7 @@ CONFIG_JOLIET=y
# CONFIG_JFS_FS is not set
# CONFIG_JFS_DEBUG is not set
# CONFIG_JFS_STATISTICS is not set
-# CONFIG_MINIX_FS is not set
+CONFIG_MINIX_FS=m
# CONFIG_VXFS_FS is not set
# CONFIG_NTFS_FS is not set
# CONFIG_NTFS_RW is not set
diff --git a/openwrt/target/linux/x86-2.6/config b/openwrt/target/linux/x86-2.6/config
index 87cc55d7ab..39c5bff019 100644
--- a/openwrt/target/linux/x86-2.6/config
+++ b/openwrt/target/linux/x86-2.6/config
@@ -1764,7 +1764,7 @@ CONFIG_XFS_FS=m
# CONFIG_XFS_SECURITY is not set
# CONFIG_XFS_POSIX_ACL is not set
# CONFIG_XFS_RT is not set
-# CONFIG_MINIX_FS is not set
+CONFIG_MINIX_FS=m
# CONFIG_ROMFS_FS is not set
# CONFIG_INOTIFY is not set
# CONFIG_QUOTA is not set