aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--include/scan.mk10
1 files changed, 8 insertions, 2 deletions
diff --git a/include/scan.mk b/include/scan.mk
index e6b21b27b0..724dbfaf17 100644
--- a/include/scan.mk
+++ b/include/scan.mk
@@ -19,9 +19,15 @@ else
endif
ifeq ($(IS_TTY),1)
- define progress
+ ifneq ($(strip $(NO_COLOR)),1)
+ define progress
printf "\033[M\r$(1)" >&2;
- endef
+ endef
+ else
+ define progress
+ :;
+ endef
+ endif
else
define progress
:;