aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/network/services/dropbear/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/package/network/services/dropbear/Makefile b/package/network/services/dropbear/Makefile
index 0a9b5c0a99..bedb000fda 100644
--- a/package/network/services/dropbear/Makefile
+++ b/package/network/services/dropbear/Makefile
@@ -53,9 +53,9 @@ define Package/dropbear
CATEGORY:=Base system
TITLE:=Small SSH2 client/server
DEPENDS:= +DROPBEAR_ZLIB:zlib
- ALTERNATIVES:=\
- 100:/usr/bin/ssh:/usr/sbin/dropbear \
- 100:/usr/bin/scp:/usr/sbin/dropbear \
+ ALTERNATIVES:=100:/usr/bin/scp:/usr/sbin/dropbear
+ $(if $(CONFIG_DROPBEAR_DBCLIENT),ALTERNATIVES+= \
+ 100:/usr/bin/ssh:/usr/sbin/dropbear,)
endef