aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--include/package-ipkg.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/include/package-ipkg.mk b/include/package-ipkg.mk
index 0bca8ae84d..a92d692121 100644
--- a/include/package-ipkg.mk
+++ b/include/package-ipkg.mk
@@ -218,8 +218,8 @@ $(_endef)
ifneq ($$(CONFIG_IPK_FILES_CHECKSUMS),)
(cd $$(IDIR_$(1)); \
( \
- find . -type f \! -path ./CONTROL/\* -exec sha256sum \{\} \; 2> /dev/null | \
- sed 's|\([[:blank:]]\)\./|\1/|' > $$(IDIR_$(1))/CONTROL/files-sha256sum \
+ find . -type f \! -path ./CONTROL/\* -exec mkhash sha256 -n \{\} \; 2> /dev/null | \
+ sed 's|\([[:blank:]]\)\./| \1/|' > $$(IDIR_$(1))/CONTROL/files-sha256sum \
) || true \
)
endif