aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/boot/uboot-envtools/files/ath791
-rw-r--r--target/linux/ath79/dts/qca9558_openmesh_mr900-v1.dts8
-rw-r--r--target/linux/ath79/dts/qca9558_openmesh_mr900.dtsi182
-rwxr-xr-xtarget/linux/ath79/generic/base-files/etc/board.d/01_leds3
-rwxr-xr-xtarget/linux/ath79/generic/base-files/etc/board.d/02_network1
-rw-r--r--target/linux/ath79/generic/base-files/etc/uci-defaults/04_led_migration3
-rw-r--r--target/linux/ath79/generic/base-files/lib/upgrade/platform.sh1
-rw-r--r--target/linux/ath79/image/generic.mk20
8 files changed, 218 insertions, 1 deletions
diff --git a/package/boot/uboot-envtools/files/ath79 b/package/boot/uboot-envtools/files/ath79
index 028b00ac43..816d3b1a88 100644
--- a/package/boot/uboot-envtools/files/ath79
+++ b/package/boot/uboot-envtools/files/ath79
@@ -50,6 +50,7 @@ ocedo,koala|\
ocedo,raccoon|\
openmesh,mr600-v1|\
openmesh,mr600-v2|\
+openmesh,mr900-v1|\
openmesh,om5p|\
openmesh,om5p-ac-v2|\
samsung,wam250|\
diff --git a/target/linux/ath79/dts/qca9558_openmesh_mr900-v1.dts b/target/linux/ath79/dts/qca9558_openmesh_mr900-v1.dts
new file mode 100644
index 0000000000..96fc9853cb
--- /dev/null
+++ b/target/linux/ath79/dts/qca9558_openmesh_mr900-v1.dts
@@ -0,0 +1,8 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "qca9558_openmesh_mr900.dtsi"
+
+/ {
+ compatible = "openmesh,mr900-v1", "qca,qca9558";
+ model = "OpenMesh MR900 v1";
+};
diff --git a/target/linux/ath79/dts/qca9558_openmesh_mr900.dtsi b/target/linux/ath79/dts/qca9558_openmesh_mr900.dtsi
new file mode 100644
index 0000000000..e506e12c31
--- /dev/null
+++ b/target/linux/ath79/dts/qca9558_openmesh_mr900.dtsi
@@ -0,0 +1,182 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "qca955x.dtsi"
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+/ {
+ chosen {
+ /delete-property/ bootargs;
+ };
+
+ aliases {
+ serial0 = &uart;
+ led-boot = &led_power_blue;
+ led-failsafe = &led_power_blue;
+ led-running = &led_power_blue;
+ led-upgrade = &led_power_blue;
+ label-mac-device = &eth0;
+ };
+
+ keys {
+ compatible = "gpio-keys";
+
+ reset {
+ label = "reset";
+ linux,code = <KEY_RESTART>;
+ gpios = <&gpio 17 GPIO_ACTIVE_LOW>;
+ };
+ };
+
+ leds {
+ compatible = "gpio-leds";
+
+ lan_blue {
+ label = "blue:lan";
+ gpios = <&gpio 12 GPIO_ACTIVE_LOW>;
+ };
+
+ wifi2g_blue {
+ label = "blue:wifi2g";
+ gpios = <&gpio 13 GPIO_ACTIVE_LOW>;
+ linux,default-trigger = "phy0tpt";
+ };
+
+ status_green {
+ label = "green:status";
+ gpios = <&gpio 19 GPIO_ACTIVE_LOW>;
+ };
+
+ status_red {
+ label = "red:status";
+ gpios = <&gpio 21 GPIO_ACTIVE_LOW>;
+ };
+
+ led_power_blue: power_blue {
+ label = "blue:power";
+ gpios = <&gpio 22 GPIO_ACTIVE_LOW>;
+ default-state = "on";
+ };
+
+ wifi5g_blue {
+ label = "blue:wifi5g";
+ gpios = <&gpio 23 GPIO_ACTIVE_LOW>;
+ linux,default-trigger = "phy1tpt";
+ };
+ };
+
+ watchdog {
+ compatible = "linux,wdt-gpio";
+ gpios = <&gpio 16 GPIO_ACTIVE_LOW>;
+ hw_algo = "toggle";
+ /* hw_margin_ms is actually 300s but driver limits it to 60s */
+ hw_margin_ms = <60000>;
+ always-running;
+ };
+};
+
+&uart {
+ status = "okay";
+};
+
+&spi {
+ status = "okay";
+
+ flash@0 {
+ compatible = "jedec,spi-nor";
+ reg = <0>;
+ spi-max-frequency = <40000000>;
+
+ /* partitions are passed via bootloader */
+ partitions {
+ compatible = "fixed-partitions";
+ #address-cells = <1>;
+ #size-cells = <1>;
+
+ partition@0 {
+ label = "u-boot";
+ reg = <0x000000 0x040000>;
+ read-only;
+ };
+
+ partition@40000 {
+ label = "u-boot-env";
+ reg = <0x040000 0x010000>;
+ };
+
+ partition@50000 {
+ label = "custom";
+ reg = <0x050000 0x060000>;
+ read-only;
+ };
+
+ partition@b0000 {
+ label = "inactive";
+ reg = <0x0b0000 0x7a0000>;
+ };
+
+ partition@850000 {
+ label = "inactive2";
+ reg = <0x850000 0x7a0000>;
+ };
+
+ art: partition@ff0000 {
+ label = "ART";
+ reg = <0xff0000 0x010000>;
+ read-only;
+ };
+ };
+ };
+};
+
+&mdio0 {
+ status = "okay";
+
+ phy-mask = <0x20>;
+
+ phy5: ethernet-phy@5 {
+ reg = <5>;
+ eee-broken-100tx;
+ eee-broken-1000t;
+ };
+};
+
+&eth0 {
+ status = "okay";
+
+ pll-data = <0xae000000 0xa0000101 0xa0001313>;
+
+ mtd-mac-address = <&art 0x0>;
+
+ phy-mode = "rgmii-rxid";
+ phy-handle = <&phy5>;
+
+ gmac-config {
+ device = <&gmac>;
+ rgmii-enabled = <1>;
+ rxd-delay = <3>;
+ rxdv-delay = <3>;
+ txd-delay = <0>;
+ txen-delay = <0>;
+ };
+};
+
+&wmac {
+ status = "okay";
+
+ mtd-cal-data = <&art 0x1000>;
+ mtd-mac-address = <&art 0x0>;
+ mtd-mac-address-increment = <1>;
+};
+
+&pcie0 {
+ status = "okay";
+
+ wifi@0,0 {
+ compatible = "pci168c,0033";
+ reg = <0x0000 0 0 0 0>;
+ mtd-mac-address = <&art 0x0>;
+ mtd-mac-address-increment = <16>;
+ };
+};
diff --git a/target/linux/ath79/generic/base-files/etc/board.d/01_leds b/target/linux/ath79/generic/base-files/etc/board.d/01_leds
index 9e5e42e268..034c2d2933 100755
--- a/target/linux/ath79/generic/base-files/etc/board.d/01_leds
+++ b/target/linux/ath79/generic/base-files/etc/board.d/01_leds
@@ -157,7 +157,8 @@ telco,t1)
;;
comfast,cf-wr752ac-v1|\
engenius,eap300-v2|\
-enterasys,ws-ap3705i)
+enterasys,ws-ap3705i|\
+openmesh,mr900-v1)
ucidef_set_led_netdev "lan" "LAN" "blue:lan" "eth0"
;;
compex,wpj344-16m|\
diff --git a/target/linux/ath79/generic/base-files/etc/board.d/02_network b/target/linux/ath79/generic/base-files/etc/board.d/02_network
index 3c37781c0e..8a15d2ad55 100755
--- a/target/linux/ath79/generic/base-files/etc/board.d/02_network
+++ b/target/linux/ath79/generic/base-files/etc/board.d/02_network
@@ -48,6 +48,7 @@ ath79_setup_interfaces()
ocedo,raccoon|\
openmesh,mr600-v1|\
openmesh,mr600-v2|\
+ openmesh,mr900-v1|\
pcs,cap324|\
pisen,ts-d084|\
pisen,wmb001n|\
diff --git a/target/linux/ath79/generic/base-files/etc/uci-defaults/04_led_migration b/target/linux/ath79/generic/base-files/etc/uci-defaults/04_led_migration
index 88c4f527b7..ad14eb2941 100644
--- a/target/linux/ath79/generic/base-files/etc/uci-defaults/04_led_migration
+++ b/target/linux/ath79/generic/base-files/etc/uci-defaults/04_led_migration
@@ -23,6 +23,9 @@ openmesh,mr600-v1)
openmesh,mr600-v2)
migrate_leds ":wlan24=:wifi2g" ":wlan58=:wifi5g"
;;
+openmesh,mr900-v1)
+ migrate_leds ":wlan24=:wifi2g" ":wlan58=:wifi5g" ":wan=:lan"
+ ;;
pcs,cap324)
migrate_leds "lan:amber=amber:lan" "lan:green=green:lan"
;;
diff --git a/target/linux/ath79/generic/base-files/lib/upgrade/platform.sh b/target/linux/ath79/generic/base-files/lib/upgrade/platform.sh
index e14adb38fa..40197cfaa8 100644
--- a/target/linux/ath79/generic/base-files/lib/upgrade/platform.sh
+++ b/target/linux/ath79/generic/base-files/lib/upgrade/platform.sh
@@ -52,6 +52,7 @@ platform_do_upgrade() {
;;
openmesh,mr600-v1|\
openmesh,mr600-v2|\
+ openmesh,mr900-v1|\
openmesh,om2p-v2|\
openmesh,om2p-v4|\
openmesh,om2p-hs-v1|\
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index 9a182cab79..9d6fd398d9 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -1552,6 +1552,26 @@ define Device/openmesh_mr600-v2
endef
TARGET_DEVICES += openmesh_mr600-v2
+define Device/openmesh_mr900-common
+ SOC := qca9558
+ DEVICE_VENDOR := OpenMesh
+ DEVICE_MODEL := MR900
+ DEVICE_PACKAGES := uboot-envtools
+ IMAGE_SIZE := 7808k
+ BLOCKSIZE := 64k
+ KERNEL := kernel-bin | append-dtb | lzma | uImage lzma | \
+ pad-to $$(BLOCKSIZE)
+ IMAGE/sysupgrade.bin := append-rootfs | pad-rootfs | \
+ openmesh-image ce_type=MR900 | append-metadata
+endef
+
+define Device/openmesh_mr900-v1
+ $(Device/openmesh_mr900-common)
+ DEVICE_VARIANT := v1
+ SUPPORTED_DEVICES += mr900
+endef
+TARGET_DEVICES += openmesh_mr900-v1
+
define Device/openmesh_om2p-common
DEVICE_VENDOR := OpenMesh
DEVICE_PACKAGES := uboot-envtools