aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/libs/mbedtls/Makefile4
-rw-r--r--package/libs/mbedtls/patches/200-config.patch22
2 files changed, 13 insertions, 13 deletions
diff --git a/package/libs/mbedtls/Makefile b/package/libs/mbedtls/Makefile
index 43cc8b05b7..7f6bf4e4c0 100644
--- a/package/libs/mbedtls/Makefile
+++ b/package/libs/mbedtls/Makefile
@@ -8,13 +8,13 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=mbedtls
-PKG_VERSION:=2.16.9
+PKG_VERSION:=2.16.10
PKG_RELEASE:=1
PKG_USE_MIPS16:=0
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://codeload.github.com/ARMmbed/mbedtls/tar.gz/v$(PKG_VERSION)?
-PKG_HASH:=fc17ff7d8c11d08f23ae2800a18269408ad2c24ea6bb8b9363e41a01c2425697
+PKG_HASH:=96257bb03b30300b2f35f861ffe204ed957e9fd0329d80646fe57fc49f589b29
PKG_BUILD_PARALLEL:=1
PKG_LICENSE:=GPL-2.0-or-later
diff --git a/package/libs/mbedtls/patches/200-config.patch b/package/libs/mbedtls/patches/200-config.patch
index 4cdeed921d..1e3d41f0eb 100644
--- a/package/libs/mbedtls/patches/200-config.patch
+++ b/package/libs/mbedtls/patches/200-config.patch
@@ -144,7 +144,7 @@
/**
* \def MBEDTLS_SSL_TRUNCATED_HMAC_COMPAT
-@@ -1779,7 +1779,7 @@
+@@ -1796,7 +1796,7 @@
*
* Comment this to disable run-time checking and save ROM space
*/
@@ -153,7 +153,7 @@
/**
* \def MBEDTLS_X509_ALLOW_EXTENSIONS_NON_V3
-@@ -2109,7 +2109,7 @@
+@@ -2126,7 +2126,7 @@
* MBEDTLS_TLS_PSK_WITH_CAMELLIA_128_GCM_SHA256
* MBEDTLS_TLS_PSK_WITH_CAMELLIA_128_CBC_SHA256
*/
@@ -162,7 +162,7 @@
/**
* \def MBEDTLS_ARIA_C
-@@ -2175,7 +2175,7 @@
+@@ -2192,7 +2192,7 @@
* This module enables the AES-CCM ciphersuites, if other requisites are
* enabled as well.
*/
@@ -171,7 +171,7 @@
/**
* \def MBEDTLS_CERTS_C
-@@ -2187,7 +2187,7 @@
+@@ -2204,7 +2204,7 @@
*
* This module is used for testing (ssl_client/server).
*/
@@ -180,7 +180,7 @@
/**
* \def MBEDTLS_CHACHA20_C
-@@ -2295,7 +2295,7 @@
+@@ -2312,7 +2312,7 @@
* \warning DES is considered a weak cipher and its use constitutes a
* security risk. We recommend considering stronger ciphers instead.
*/
@@ -189,7 +189,7 @@
/**
* \def MBEDTLS_DHM_C
-@@ -2458,7 +2458,7 @@
+@@ -2475,7 +2475,7 @@
* This module adds support for the Hashed Message Authentication Code
* (HMAC)-based key derivation function (HKDF).
*/
@@ -198,7 +198,7 @@
/**
* \def MBEDTLS_HMAC_DRBG_C
-@@ -2768,7 +2768,7 @@
+@@ -2785,7 +2785,7 @@
*
* This module enables abstraction of common (libc) functions.
*/
@@ -207,7 +207,7 @@
/**
* \def MBEDTLS_POLY1305_C
-@@ -2789,7 +2789,7 @@
+@@ -2806,7 +2806,7 @@
* Caller: library/md.c
*
*/
@@ -216,7 +216,7 @@
/**
* \def MBEDTLS_RSA_C
-@@ -2896,7 +2896,7 @@
+@@ -2913,7 +2913,7 @@
*
* Requires: MBEDTLS_CIPHER_C
*/
@@ -225,7 +225,7 @@
/**
* \def MBEDTLS_SSL_CLI_C
-@@ -2996,7 +2996,7 @@
+@@ -3013,7 +3013,7 @@
*
* This module provides run-time version information.
*/
@@ -234,7 +234,7 @@
/**
* \def MBEDTLS_X509_USE_C
-@@ -3106,7 +3106,7 @@
+@@ -3123,7 +3123,7 @@
* Module: library/xtea.c
* Caller:
*/