aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--include/autotools.mk6
1 files changed, 3 insertions, 3 deletions
diff --git a/include/autotools.mk b/include/autotools.mk
index 1ce25bc9f6..f7b633d96c 100644
--- a/include/autotools.mk
+++ b/include/autotools.mk
@@ -36,14 +36,14 @@ define autoreconf
$(foreach p,$(3), \
if [ -f $(p)/configure.ac ] || [ -f $(p)/configure.in ]; then \
[ -d $(p)/autom4te.cache ] && rm -rf autom4te.cache; \
- touch NEWS AUTHORS COPYING ChangeLog; \
+ [ -e $(p)/config.rpath ] || \
+ ln -s $(SCRIPT_DIR)/config.rpath $(p)/config.rpath; \
+ touch NEWS AUTHORS COPYING ABOUT-NLS ChangeLog; \
$(AM_TOOL_PATHS) $(STAGING_DIR_HOST)/bin/autoreconf -v -f -i -s \
$(if $(word 2,$(3)),--no-recursive) \
-B $(STAGING_DIR_HOST)/share/aclocal \
$(patsubst %,-I %,$(5)) \
$(patsubst %,-I %,$(4)) $(4) || true; \
- [ -e $(p)/config.rpath ] || \
- ln -s $(SCRIPT_DIR)/config.rpath $(p)/config.rpath;
fi; \
) \
);