aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--include/target.mk8
-rw-r--r--package/base-files/Makefile2
2 files changed, 8 insertions, 2 deletions
diff --git a/include/target.mk b/include/target.mk
index 31ce592c8b..a2e76f8149 100644
--- a/include/target.mk
+++ b/include/target.mk
@@ -15,7 +15,6 @@ DEVICE_TYPE?=router
# Default packages - the really basic set
DEFAULT_PACKAGES:=\
base-files \
- busybox \
ca-bundle \
dropbear \
fstools \
@@ -30,6 +29,13 @@ DEFAULT_PACKAGES:=\
uclient-fetch \
urandom-seed \
urngd
+
+ifneq ($(CONFIG_SELINUX),)
+DEFAULT_PACKAGES+=busybox-selinux procd-selinux
+else
+DEFAULT_PACKAGES+=busybox procd
+endif
+
# For the basic set
DEFAULT_PACKAGES.basic:=
# For nas targets
diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index bf6b5c3c9a..27bf7ae3f9 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -37,7 +37,7 @@ endif
define Package/base-files
SECTION:=base
CATEGORY:=Base system
- DEPENDS:=+netifd +libc +procd +jsonfilter +SIGNED_PACKAGES:usign +SIGNED_PACKAGES:openwrt-keyring +NAND_SUPPORT:ubi-utils +fstools +fwtool
+ DEPENDS:=+netifd +libc +jsonfilter +SIGNED_PACKAGES:usign +SIGNED_PACKAGES:openwrt-keyring +NAND_SUPPORT:ubi-utils +fstools +fwtool
TITLE:=Base filesystem for OpenWrt
URL:=http://openwrt.org/
VERSION:=$(PKG_RELEASE)-$(REVISION)