aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--config/Config-images.in7
-rw-r--r--include/image.mk1
2 files changed, 0 insertions, 8 deletions
diff --git a/config/Config-images.in b/config/Config-images.in
index 05b817bad4..1a6951dfb7 100644
--- a/config/Config-images.in
+++ b/config/Config-images.in
@@ -73,13 +73,6 @@ menu "Target Images"
help
Build an ext4 root filesystem.
- config TARGET_EXT4_MAXINODE
- int "Maximum number of inodes in root filesystem"
- depends on TARGET_ROOTFS_EXT4FS
- default 6000
- help
- Select the maximum number of inodes in the root filesystem.
-
config TARGET_EXT4_RESERVED_PCT
int "Percentage of reserved blocks in root filesystem"
depends on TARGET_ROOTFS_EXT4FS
diff --git a/include/image.mk b/include/image.mk
index 59dd66fa9c..8b183ab58a 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -244,7 +244,6 @@ E2SIZE=$(shell echo $$(($(CONFIG_TARGET_ROOTFS_PARTSIZE)*1024*1024)))
define Image/mkfs/ext4
$(STAGING_DIR_HOST)/bin/make_ext4fs \
-l $(E2SIZE) -b $(CONFIG_TARGET_EXT4_BLOCKSIZE) \
- -i $(CONFIG_TARGET_EXT4_MAXINODE) \
$(if $(CONFIG_TARGET_EXT4_RESERVED_PCT),-m $(CONFIG_TARGET_EXT4_RESERVED_PCT)) \
$(if $(CONFIG_TARGET_EXT4_JOURNAL),,-J) \
$(if $(SOURCE_DATE_EPOCH),-T $(SOURCE_DATE_EPOCH)) \