aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--include/package-version-override.mk70
-rw-r--r--target/linux/lantiq/Makefile4
-rw-r--r--target/linux/lantiq/ase/config-default19
-rw-r--r--target/linux/lantiq/ase/profiles/001-netgear.mk5
-rw-r--r--target/linux/lantiq/ase/target.mk10
5 files changed, 2 insertions, 106 deletions
diff --git a/include/package-version-override.mk b/include/package-version-override.mk
deleted file mode 100644
index 2c1741eef1..0000000000
--- a/include/package-version-override.mk
+++ /dev/null
@@ -1,70 +0,0 @@
-# remember the provided package version
-PKG_VERSION_ORGINAL:=$(PKG_VERSION)
-
-# in case that another version is provided, overwrite the original
-ifeq ($(CONFIG_$(PKG_NAME)_USE_CUSTOM_VERSION),y)
-PKG_VERSION:=$(call qstrip,$(CONFIG_$(PKG_NAME)_CUSTOM_VERSION))
-PKG_SOURCE:=$(subst $(PKG_VERSION_ORGINAL),$(PKG_VERSION),$(PKG_SOURCE))
-PKG_MD5SUM:=
-endif
-
-# package specific configuration
-# if includeded the package version can be overwritten within the .config file (instead of changing the package specific Makefile)
-define Package/$(PKG_NAME)/override_version
- menu "overwrite package version"
- depends on PACKAGE_$(PKG_NAME)
- config $(PKG_NAME)_USE_CUSTOM_VERSION
- depends on PACKAGE_$(PKG_NAME)
- bool "Use custom package version"
- default n
- config $(PKG_NAME)_CUSTOM_VERSION
- depends on $(PKG_NAME)_USE_CUSTOM_VERSION
- string "$(PKG_BASE_NAME) version as string (default version: $(PKG_VERSION_ORGINAL))"
- default "$(PKG_VERSION_ORGINAL)"
- endmenu
-endef
-
-# in case that an customer source path is provided, set the acc. default variable
-ifeq ($(CONFIG_$(PKG_NAME)_USE_CUSTOM_SOURCE_DIR),y)
-PKG_DEFAULT_CUSTOM_SOURCE_DIR:= $(call qstrip,$(CONFIG_$(PKG_NAME)_CUSTOM_SOURCE_DIR))
-endif
-
-# package specific configuration
-# if includeded the package source path can be overwritten within the .config file (instead of changing the package specific Makefile)
-# instead of using a source ball (eg tar.gz) the specified path will point to the location of the sources
-define Package/$(PKG_NAME)/override_source_path
- menu "custom source directory"
- depends on PACKAGE_$(PKG_NAME)
- config $(PKG_NAME)_USE_CUSTOM_SOURCE_DIR
- depends on PACKAGE_$(PKG_NAME)
- bool "Use custom source directory"
- default n
- config $(PKG_NAME)_CUSTOM_SOURCE_DIR
- depends on $(PKG_NAME)_USE_CUSTOM_SOURCE_DIR
- string "Custom source directory"
- default "$(PKG_DEFAULT_CUSTOM_SOURCE_DIR)"
- endmenu
-endef
-
-# default:
-# include both configurations as long this file is included before package.mk
-# in case that you're defining your own onfiguration within the package Makefile just include the stuff by yourself
-define Package/$(PKG_NAME)/config
- $(call Package/$(PKG_NAME)/override_version)
- $(call Package/$(PKG_NAME)/override_source_path)
-endef
-
-# hook for custom source path
-# in case that the specified path is valid a link to the PKG_SOURCE_DIR is created
-# otherwise the make is stopped
-define prepare_custom_source_directory
- if [ -d $(CONFIG_$(PKG_NAME)_CUSTOM_SOURCE_DIR) ]; then \
- rm -Rf $(PKG_BUILD_DIR); \
- echo "Preparing Custom Source Directory link: $(CONFIG_$(PKG_NAME)_CUSTOM_SOURCE_DIR)"; \
- ln -snf $(CONFIG_$(PKG_NAME)_CUSTOM_SOURCE_DIR) $(PKG_BUILD_DIR); \
- else \
- echo "Custom Source Directory $(CONFIG_$(PKG_NAME)_CUSTOM_SOURCE_DIR) is invalid"; \
- false; \
- fi
-endef
-
diff --git a/target/linux/lantiq/Makefile b/target/linux/lantiq/Makefile
index d7f75683e0..6653cc407f 100644
--- a/target/linux/lantiq/Makefile
+++ b/target/linux/lantiq/Makefile
@@ -7,9 +7,9 @@
include $(TOPDIR)/rules.mk
BOARD:=lantiq
-BOARDNAME:=Lantiq GPON/XWAY/SVIP
+BOARDNAME:=Lantiq
FEATURES:=squashfs ubifs
-SUBTARGETS=xway xrx200 ase falcon
+SUBTARGETS=xway xrx200
LINUX_VERSION:=3.10.34
diff --git a/target/linux/lantiq/ase/config-default b/target/linux/lantiq/ase/config-default
deleted file mode 100644
index 79b559592a..0000000000
--- a/target/linux/lantiq/ase/config-default
+++ /dev/null
@@ -1,19 +0,0 @@
-CONFIG_AR8216_PHY=y
-CONFIG_INPUT=y
-CONFIG_INPUT_EVDEV=y
-CONFIG_INPUT_POLLDEV=y
-# CONFIG_ISDN is not set
-# CONFIG_LANTIQ_PHY is not set
-# CONFIG_M25PXX_USE_FAST_READ is not set
-CONFIG_MTD_M25P80=y
-# CONFIG_RTL8366_SMI is not set
-CONFIG_SOC_AMAZON_SE=y
-# CONFIG_SOC_XWAY is not set
-CONFIG_SPI=y
-CONFIG_SPI_BITBANG=y
-CONFIG_SPI_MASTER=y
-CONFIG_SPI_XWAY=y
-# CONFIG_USB_ARCH_HAS_EHCI is not set
-# CONFIG_USB_ARCH_HAS_OHCI is not set
-# CONFIG_USB_ARCH_HAS_XHCI is not set
-CONFIG_USB_SUPPORT=y
diff --git a/target/linux/lantiq/ase/profiles/001-netgear.mk b/target/linux/lantiq/ase/profiles/001-netgear.mk
deleted file mode 100644
index 3636d3889a..0000000000
--- a/target/linux/lantiq/ase/profiles/001-netgear.mk
+++ /dev/null
@@ -1,5 +0,0 @@
-define Profile/DGN1000B
- NAME:=Netgear DGN1000B
-endef
-
-$(eval $(call Profile,DGN1000B))
diff --git a/target/linux/lantiq/ase/target.mk b/target/linux/lantiq/ase/target.mk
deleted file mode 100644
index a052dd2ce7..0000000000
--- a/target/linux/lantiq/ase/target.mk
+++ /dev/null
@@ -1,10 +0,0 @@
-ARCH:=mips
-SUBTARGET:=ase
-BOARDNAME:=Amazon-SE
-FEATURES:=squashfs atm
-
-DEFAULT_PACKAGES+=kmod-pppoa ppp-mod-pppoa linux-atm atm-tools br2684ctl kmod-ltq-dsl-ase ltq-dsl-app
-
-define Target/Description
- Lantiq ASE
-endef