aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/network/services/lldpd/Makefile8
1 files changed, 3 insertions, 5 deletions
diff --git a/package/network/services/lldpd/Makefile b/package/network/services/lldpd/Makefile
index 97ae23e1d9..801a772e02 100644
--- a/package/network/services/lldpd/Makefile
+++ b/package/network/services/lldpd/Makefile
@@ -85,10 +85,6 @@ define Package/lldpd/conffiles
/etc/config/lldpd
endef
-CONFIGURE_VARS += \
- $(if $(CONFIG_USE_GLIBC),,libbsd_CFLAGS=-ldo-not-link-bsd) \
- $(if $(CONFIG_USE_GLIBC),,libbsd_LDFLAGS=-ldo-not-link-bsd)
-
CONFIGURE_ARGS += \
$(if $(CONFIG_LLDPD_WITH_PRIVSEP), \
--with-privsep-user=lldp \
@@ -113,6 +109,8 @@ CONFIGURE_ARGS += \
# there is no flag to disable libbsd
CONFIGURE_VARS += \
- $(if $(CONFIG_USE_GLIBC),,libbsd_LIBS="-lNONexistent")
+ $(if $(CONFIG_USE_GLIBC),,libbsd_CFLAGS=-ldo-not-link-bsd) \
+ $(if $(CONFIG_USE_GLIBC),,libbsd_LDFLAGS=-ldo-not-link-bsd) \
+ $(if $(CONFIG_USE_GLIBC),,libbsd_LIBS="-lNONexistent")
$(eval $(call BuildPackage,lldpd))