aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/kernel/linux/modules/usb.mk2
-rw-r--r--target/linux/mxs/modules.mk16
2 files changed, 1 insertions, 17 deletions
diff --git a/package/kernel/linux/modules/usb.mk b/package/kernel/linux/modules/usb.mk
index f4fecd6f5c..37b3eb102a 100644
--- a/package/kernel/linux/modules/usb.mk
+++ b/package/kernel/linux/modules/usb.mk
@@ -1364,7 +1364,7 @@ $(eval $(call KernelPackage,usb-chipidea,1))
define KernelPackage/usb-mxs-phy
TITLE:=Support for Freescale MXS USB PHY
- DEPENDS:=@TARGET_imx6
+ DEPENDS:=@TARGET_imx6||TARGET_mxs +TARGET_mxs:kmod-usb-chipidea-imx
KCONFIG:=CONFIG_USB_MXS_PHY
FILES:=\
$(LINUX_DIR)/drivers/usb/phy/phy-mxs-usb.ko
diff --git a/target/linux/mxs/modules.mk b/target/linux/mxs/modules.mk
index cbb870b49d..0584a731bd 100644
--- a/target/linux/mxs/modules.mk
+++ b/target/linux/mxs/modules.mk
@@ -49,22 +49,6 @@ endef
$(eval $(call KernelPackage,usb-chipidea-imx,1))
-define KernelPackage/usb-mxs-phy
- TITLE:=Support for Freescale MXS USB PHY controllers
- DEPENDS:=+kmod-usb-chipidea-imx
- KCONFIG:= \
- CONFIG_USB_MXS_PHY
- FILES:=$(LINUX_DIR)/drivers/usb/phy/phy-mxs-usb.ko
- AUTOLOAD:=$(call AutoLoad,50,phy-mxs-usb,1)
- $(call AddDepends/usb)
-endef
-
-define KernelPackage/usb-mxs-phy/description
- Kernel support for Freescale MXS USB PHY controllers
-endef
-
-$(eval $(call KernelPackage,usb-mxs-phy,1))
-
define KernelPackage/sound-soc-mxs
TITLE:=Freescale i.MX23/i.MX28 built-in SoC sound support
KCONFIG:= \