aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rwxr-xr-xtarget/linux/bcm53xx/base-files/etc/board.d/02_network19
-rw-r--r--target/linux/bcm53xx/image/Makefile18
2 files changed, 36 insertions, 1 deletions
diff --git a/target/linux/bcm53xx/base-files/etc/board.d/02_network b/target/linux/bcm53xx/base-files/etc/board.d/02_network
index f86f12407f..b3d614d6a2 100755
--- a/target/linux/bcm53xx/base-files/etc/board.d/02_network
+++ b/target/linux/bcm53xx/base-files/etc/board.d/02_network
@@ -36,6 +36,15 @@ bcm53xx_setup_interfaces()
ucidef_add_switch "switch0" \
"0:wan" "1:lan:4" "2:lan:3" "3:lan:2" "4:lan:1" "5@eth0"
;;
+ luxul,xap-1610-v1)
+ ucidef_add_switch "switch0" \
+ "0:lan" "1:lan" "5@eth0"
+ ucidef_set_interface_lan "eth0.1" "dhcp"
+ ;;
+ luxul,xwr-3150-v1)
+ ucidef_add_switch "switch0" \
+ "0:lan:1" "1:lan:2" "2:lan:3" "3:lan:4" "4:wan" "5@eth0"
+ ;;
phicomm,k3)
ucidef_add_switch "switch0" \
"0:lan" "1:lan" "2:lan" "3:wan" "5@eth0"
@@ -87,20 +96,28 @@ bcm53xx_setup_macs()
case "$board" in
asus,rt-ac87u)
etXmacaddr=$(nvram get et1macaddr)
+ offset=1
;;
dlink,dir-885l | \
netgear,r7900 | \
netgear,r8000 | \
netgear,r8500)
etXmacaddr=$(nvram get et2macaddr)
+ offset=1
+ ;;
+ luxul,xwr-3100v1 | \
+ luxul,xwr-3150-v1)
+ etXmacaddr=$(nvram get et0macaddr)
+ offset=5
;;
*)
etXmacaddr=$(nvram get et0macaddr)
+ offset=1
;;
esac
# If WAN MAC isn't explicitly set, calculate it using base MAC as reference.
- [ -z "$wan_macaddr" -a -n "$etXmacaddr" ] && wan_macaddr=$(macaddr_add "$etXmacaddr" 1)
+ [ -z "$wan_macaddr" -a -n "$etXmacaddr" ] && wan_macaddr=$(macaddr_add "$etXmacaddr" $offset)
[ -n "$wan_macaddr" ] && ucidef_set_interface_macaddr "wan" "$wan_macaddr"
}
diff --git a/target/linux/bcm53xx/image/Makefile b/target/linux/bcm53xx/image/Makefile
index 610af03abe..b3ec1e99a2 100644
--- a/target/linux/bcm53xx/image/Makefile
+++ b/target/linux/bcm53xx/image/Makefile
@@ -291,6 +291,15 @@ define Device/luxul-abr-4500
endef
TARGET_DEVICES += luxul-abr-4500
+define Device/luxul-xap-1610
+ $(Device/luxul)
+ DEVICE_MODEL := XAP-1610
+ DEVICE_PACKAGES := $(BRCMFMAC_4366C0)
+ IMAGE/lxl := append-rootfs | trx-serial | luxul-lxl
+ LUXUL_BOARD := XAP-1610
+endef
+TARGET_DEVICES += luxul-xap-1610
+
define Device/luxul-xbr-4500
$(Device/luxul)
DEVICE_MODEL := XBR-4500
@@ -299,6 +308,15 @@ define Device/luxul-xbr-4500
endef
TARGET_DEVICES += luxul-xbr-4500
+define Device/luxul-xwr-3150
+ $(Device/luxul)
+ DEVICE_MODEL := XWR-3150
+ DEVICE_PACKAGES := $(BRCMFMAC_4366C0) $(USB3_PACKAGES)
+ DEVICE_DTS := bcm47094-luxul-xwr-3150-v1
+ LUXUL_BOARD := XWR-3150
+endef
+TARGET_DEVICES += luxul-xwr-3150
+
define Device/netgear
DEVICE_VENDOR := NETGEAR
IMAGES := chk