aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--tools/Makefile3
-rw-r--r--tools/flex/Makefile32
2 files changed, 34 insertions, 1 deletions
diff --git a/tools/Makefile b/tools/Makefile
index c852383241..81a6e5c8f0 100644
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -14,7 +14,7 @@ ifeq ($(CONFIG_EXTERNAL_TOOLCHAIN),)
tools-$(CONFIG_GCC_VERSION_4_3)$(CONFIG_GCC_VERSION_4_4)$(CONFIG_GCC_VERSION_4_5) += gmp mpfr
tools-$(CONFIG_GCC_VERSION_4_5) += mpc libelf
endif
-tools-y += m4 autoconf automake bison pkg-config sed mklibs
+tools-y += m4 autoconf automake flex bison pkg-config sed mklibs
tools-y += sstrip ipkg-utils genext2fs e2fsprogs mtd-utils mkimage
tools-y += firmware-utils patch-cmdline quilt yaffs2 flock
tools-y += xorg-macros xz
@@ -34,6 +34,7 @@ ifdef CONFIG_GCC_USE_GRAPHITE
endif
# builddir dependencies
+$(curdir)/bison/compile := $(curdir)/flex/install
$(curdir)/pkg-config/compile := $(curdir)/sed/install
$(curdir)/squashfs/compile := $(curdir)/lzma-old/install
$(curdir)/squashfs4/compile := $(curdir)/lzma/install
diff --git a/tools/flex/Makefile b/tools/flex/Makefile
new file mode 100644
index 0000000000..9d4ae136b4
--- /dev/null
+++ b/tools/flex/Makefile
@@ -0,0 +1,32 @@
+#
+# Copyright (C) 2008 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=flex
+PKG_VERSION:=2.5.35
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=@SF/$(PKG_NAME)
+PKG_MD5SUM:=10714e50cea54dc7a227e3eddcd44d57
+PKG_CAT:=bzcat
+
+include $(INCLUDE_DIR)/host-build.mk
+
+define Host/Compile
+ $(MAKE) -C $(HOST_BUILD_DIR)
+endef
+
+define Host/Install
+ $(MAKE) -C $(HOST_BUILD_DIR) install
+endef
+
+define Host/Clean
+ -$(MAKE) -C $(HOST_BUILD_DIR) uninstall
+ $(call Host/Clean/Default)
+endef
+
+$(eval $(call HostBuild))