aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/kernel/modules/leds.mk2
-rw-r--r--target/linux/x86/alix2/target.mk2
2 files changed, 3 insertions, 1 deletions
diff --git a/package/kernel/modules/leds.mk b/package/kernel/modules/leds.mk
index 43f3ce930e..e6506fa558 100644
--- a/package/kernel/modules/leds.mk
+++ b/package/kernel/modules/leds.mk
@@ -8,6 +8,7 @@
LEDS_MENU:=LED modules
+ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),lt,2.6.39)),1)
define KernelPackage/leds-alix
SUBMENU:=$(LEDS_MENU)
TITLE:=PCengines ALIX LED support
@@ -22,6 +23,7 @@ define KernelPackage/leds-alix/description
endef
$(eval $(call KernelPackage,leds-alix))
+endif
define KernelPackage/leds-gpio
diff --git a/target/linux/x86/alix2/target.mk b/target/linux/x86/alix2/target.mk
index 0c1c3d2dcb..cece30e173 100644
--- a/target/linux/x86/alix2/target.mk
+++ b/target/linux/x86/alix2/target.mk
@@ -7,7 +7,7 @@ DEFAULT_PACKAGES += \
kmod-wdt-geode kmod-cs5535-clockevt kmod-cs5535-mfgpt \
kmod-cs5536 \
kmod-hwmon-core kmod-hwmon-lm90 \
- kmod-via-rhine kmod-leds-alix \
+ kmod-via-rhine \
kmod-i2c-core kmod-i2c-gpio \
kmod-i2c-algo-bit kmod-i2c-algo-pca kmod-i2c-algo-pcf \
kmod-i2c-scx200-acb \