aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--include/subdir.mk3
-rw-r--r--target/Makefile1
-rw-r--r--target/imagebuilder/Makefile2
-rw-r--r--target/sdk/Makefile2
4 files changed, 5 insertions, 3 deletions
diff --git a/include/subdir.mk b/include/subdir.mk
index 4fa1bdfd52..3bf1a4bb79 100644
--- a/include/subdir.mk
+++ b/include/subdir.mk
@@ -28,8 +28,7 @@ define subdir
$(call warn,$(1),d,BD $(1)/$(bd))
$(foreach target,$(SUBTARGETS),
$(call warn_eval,$(1)/$(bd),t,T,$(1)/$(bd)/$(target): $(if $(QUILT),,$($(1)/$(bd)/$(target)) $(call $(1)//$(target),$(1)/$(bd))))
- +$(if $(findstring $(bd),$($(1)/builddirs-parallel)),$$(SUBMAKE),$(_SINGLE)$$(SUBMAKE) -j1) \
- -C $(1)/$(bd) $(target) $(if $(findstring $(bd),$($(1)/builddirs-ignore-$(target))), || $(call MESSAGE, ERROR: $(1)/$(bd) failed to build.))
+ +$$(SUBMAKE) -C $(1)/$(bd) $(target) $(if $(findstring $(bd),$($(1)/builddirs-ignore-$(target))), || $(call MESSAGE, ERROR: $(1)/$(bd) failed to build.))
$$(if $(call debug,$(1)/$(bd),v),,.SILENT: $(1)/$(bd)/$(target))
# legacy targets
diff --git a/target/Makefile b/target/Makefile
index 4c746e2f00..3d36d26718 100644
--- a/target/Makefile
+++ b/target/Makefile
@@ -6,7 +6,6 @@
#
curdir:=target
-$(curdir)/builddirs-parallel:=linux
$(curdir)/builddirs:=linux sdk imagebuilder
$(curdir)/builddirs-default:=linux
$(curdir)/builddirs-install:=linux $(if $(CONFIG_SDK),sdk) $(if $(CONFIG_IB),imagebuilder)
diff --git a/target/imagebuilder/Makefile b/target/imagebuilder/Makefile
index dcd5ca82cc..8a3ac7fed9 100644
--- a/target/imagebuilder/Makefile
+++ b/target/imagebuilder/Makefile
@@ -10,6 +10,8 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/kernel.mk
include $(INCLUDE_DIR)/host.mk
+override MAKEFLAGS=
+
PKG_OS:=$(shell uname -s)
PKG_CPU:=$(shell uname -m | sed "s/ //g")
diff --git a/target/sdk/Makefile b/target/sdk/Makefile
index 05ae321616..de00da825b 100644
--- a/target/sdk/Makefile
+++ b/target/sdk/Makefile
@@ -10,6 +10,8 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/kernel.mk
include $(INCLUDE_DIR)/host.mk
+override MAKEFLAGS=
+
PKG_OS:=$(shell uname -s)
PKG_CPU:=$(shell uname -m)