aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--openwrt/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/openwrt/Makefile b/openwrt/Makefile
index c2e628051a..81ecc43f8a 100644
--- a/openwrt/Makefile
+++ b/openwrt/Makefile
@@ -107,6 +107,8 @@ $(STAGING_DIR):
$(TARGET_DIR):
@mkdir -p $(TARGET_DIR)
cp -a target/default/target_skeleton/* $(TARGET_DIR)/
+ mkdir $(TARGET_DIR)/{proc,dev,jffs,tmp,usr/sbin}
+ chmod 1777 $(TARGET_DIR)/tmp
-find $(TARGET_DIR) -type d -name CVS -exec rm -rf {} \; > /dev/null 2>&1
source: $(TARGETS_SOURCE)