aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--config/Config-devel.in9
-rw-r--r--include/kernel-build.mk6
2 files changed, 6 insertions, 9 deletions
diff --git a/config/Config-devel.in b/config/Config-devel.in
index 30fbd6f7a9..fd7c3ead1e 100644
--- a/config/Config-devel.in
+++ b/config/Config-devel.in
@@ -90,13 +90,14 @@ menuconfig DEVEL
In this instance, the --reference option of git clone will
be used thus creating a quick local clone of your repo.
- config KERNEL_GIT_BRANCH
- string "Enter git branch to clone" if DEVEL
+ config KERNEL_GIT_REF
+ string "Enter git ref at which to checkout" if DEVEL
depends on (KERNEL_GIT_CLONE_URI != "")
default ""
help
- Enter the branch name to checkout after cloning the git repository.
- In this instance, the --branch option of git clone will be used.
+ Enter the git ref at which to checkout the git repository
+ after it is cloned, and before making it a tar-ball.
+ It can be a git hash or a branch name.
If unused, the clone's repository HEAD will be checked-out.
config BUILD_LOG
diff --git a/include/kernel-build.mk b/include/kernel-build.mk
index 5c58e443df..c3658c216a 100644
--- a/include/kernel-build.mk
+++ b/include/kernel-build.mk
@@ -50,14 +50,10 @@ ifneq ($(strip $(CONFIG_KERNEL_GIT_LOCAL_REPOSITORY)),"")
KERNEL_GIT_OPTS+=--reference $(CONFIG_KERNEL_GIT_LOCAL_REPOSITORY)
endif
-ifneq ($(strip $(CONFIG_KERNEL_GIT_BRANCH)),"")
- KERNEL_GIT_OPTS+=--branch $(CONFIG_KERNEL_GIT_BRANCH)
-endif
-
define Download/git-kernel
URL:=$(call qstrip,$(CONFIG_KERNEL_GIT_CLONE_URI))
PROTO:=git
- VERSION:=$(CONFIG_KERNEL_GIT_BRANCH)
+ VERSION:=$(CONFIG_KERNEL_GIT_REF)
FILE:=$(LINUX_SOURCE)
SUBDIR:=linux-$(LINUX_VERSION)
OPTS:=$(KERNEL_GIT_OPTS)