aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/kernel/linux/modules/other.mk10
1 files changed, 7 insertions, 3 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index 7e18a21db3..279c159878 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -228,9 +228,13 @@ define KernelPackage/gpio-mcp23s08
SUBMENU:=$(OTHER_MENU)
TITLE:=Microchip MCP23xxx I/O expander
DEPENDS:=@GPIO_SUPPORT +kmod-i2c-core
- KCONFIG:=CONFIG_GPIO_MCP23S08
- FILES:=$(LINUX_DIR)/drivers/gpio/gpio-mcp23s08.ko
- AUTOLOAD:=$(call AutoLoad,40,gpio-mcp23s08)
+ KCONFIG:= \
+ CONFIG_GPIO_MCP23S08 \
+ CONFIG_PINCTRL_MCP23S08
+ FILES:= \
+ $(LINUX_DIR)/drivers/gpio/gpio-mcp23s08.ko@lt4.13 \
+ $(LINUX_DIR)/drivers/pinctrl/pinctrl-mcp23s08.ko@ge4.13
+ AUTOLOAD:=$(call AutoLoad,40,gpio-mcp23s08@lt4.13 pinctrl-mcp23s08@ge4.13)
endef
define KernelPackage/gpio-mcp23s08/description